How to upgrade Apache POI version?

cancel
Showing results for 
Search instead for 
Did you mean: 
iceja
Active Member II

How to upgrade Apache POI version?

 

I have Alfresco 5.2 project with Apache POI version "3.10.1-20151016-alfresco-patched" and I need to update in up to 5.0.0 version (or 4.0.0). I have add the section

        <dependency>
            <groupId>org.apache.poi</groupId>
            <artifactId>poi</artifactId>
            <version>5.0.0</version>
        </dependency>

But as I can see the class XWPFTableCell still has an old version: /home/katya3/.m2/repository/org/apache/poi/poi-ooxml/3.10.1-20151016-alfresco-patched/poi-ooxml-3.10.1-20151016-alfresco-patched-sources.jar!/org/apache/poi/xwpf/usermodel/XWPFTableCell.java Also I can not see the required method setWidth (added in 4.0.0) so the version is still old. Please teach me how to upgrade?

Thank you!

2 Replies
angelborroy
Alfresco Employee

Re: How to upgrade Apache POI version?

IMO upgrading Alfresco JAR libraries is not the right approach, as dependencies have been build and tested for that specific version of the Repository.

Probably you can explore any other alternative.

Software Engineer in Alfresco Search Team.
iceja
Active Member II

Re: How to upgrade Apache POI version?

this reply was added by mistake