I followed the simple workflow tutorial by " http://ecmarchitect.com/alfresco-developer-series-tutorials/workflow/tutorial/tutorial.html" i am getting this error Please assist

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
chetantewari
Member II

I followed the simple workflow tutorial by " http://ecmarchitect.com/alfresco-developer-series-tutorials/workflow/tutorial/tutorial.html" i am getting this error Please assist

i have uploaded the error i am getting please help me with this

[INFO] ------------------------------------------------------------------------

[INFO] Reactor Summary for AIO - SDK 3.0 1.0-SNAPSHOT:

[INFO]

[INFO] AIO - SDK 3.0 ...................................... FAILURE [ 23.188 s]

[INFO] Alfresco Platform/Repository JAR Module ............ SUCCESS [ 10.205 s]

[INFO] Alfresco Share JAR Module .......................... SUCCESS [  1.298 s]

[INFO] Integration Tests Module ........................... SUCCESS [  2.786 s]

[INFO] ------------------------------------------------------------------------

[INFO] BUILD FAILURE

[INFO] ------------------------------------------------------------------------

[INFO] Total time:  39.017 s

[INFO] Finished at: 2018-12-10T14:36:33+05:30

[INFO] ------------------------------------------------------------------------

[ERROR] Failed to execute goal org.alfresco.maven.plugin:alfresco-maven-plugin:3.0.1:run (default-cli) on project workflow: Unable to execute mojo: Unable to resolve artifact. Could not transfer artifact com.tcs:content-tutorial-platform-jar:amp:1.0-SNAPSHOT from/to alfresco-private-repository (https://artifacts.alfresco.com/nexus/content/groups/private): Not authorized

[ERROR]   com.tcs:content-tutorial-platform-jar:amp:1.0-SNAPSHOT

[ERROR]

[ERROR] from the specified remote repositories:

[ERROR]   alfresco-public (https://artifacts.alfresco.com/nexus/content/groups/public, releases=true, snapshots=true),

[ERROR]   alfresco-public-snapshots (https://artifacts.alfresco.com/nexus/content/groups/public-snapshots, releases=true, snapshots=true),

[ERROR]   alfresco-private-repository (https://artifacts.alfresco.com/nexus/content/groups/private, releases=true, snapshots=true),

[ERROR]   central (https://repo.maven.apache.org/maven2, releases=true, snapshots=false)

[ERROR] -> [Help 1]

[ERROR]

[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

[ERROR] Re-run Maven using the -X switch to enable full debug logging.

[ERROR]

[ERROR] For more information about the errors and possible solutions, please read the following articles:

[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException

6 Replies
krutik_jayswal
Senior Member II

Re: I followed the simple workflow tutorial by " http://ecmarchitect.com/alfresco-developer-series-tutorials/workflow/tutorial/tutorial.html" i am getting this error Please assist

Add the first error which is there in error log, If alfresco failed to start with some spring bean issue or some other issue.It will populate this kind of error repeatedly.

Adding actual log and the configuration which you did will help in resolving the error.

chetantewari
Member II

Re: I followed the simple workflow tutorial by " http://ecmarchitect.com/alfresco-developer-series-tutorials/workflow/tutorial/tutorial.html" i am getting this error Please assist

you need full log file

krutik_jayswal
Senior Member II

Re: I followed the simple workflow tutorial by " http://ecmarchitect.com/alfresco-developer-series-tutorials/workflow/tutorial/tutorial.html" i am getting this error Please assist

yes

yash_patel_c2
Established Member

Re: I followed the simple workflow tutorial by " http://ecmarchitect.com/alfresco-developer-series-tutorials/workflow/tutorial/tutorial.html" i am getting this error Please assist

Hi Chetan Tewari‌,

Kindly attach proper log file with the question so that we can have proper idea.

Thanks 

ContCentric

vidhipanchal
Established Member

Re: I followed the simple workflow tutorial by " http://ecmarchitect.com/alfresco-developer-series-tutorials/workflow/tutorial/tutorial.html" i am getting this error Please assist

Hi Chetan,

Please attach Spring bean configuration and kindly mention which files you are created.

Are you add any extra dependency? 

Thanks,

ContCentric

jpotts
Advanced II

Re: I followed the simple workflow tutorial by " http://ecmarchitect.com/alfresco-developer-series-tutorials/workflow/tutorial/tutorial.html" i am getting this error Please assist

It looks to me like you are using com.tcs as the group. The workflow tutorial depends on previous tutorials. In this case it is looking for the content-tutorial AMP. If you haven't already, switch into the content tutorial and do a "mvn install -DskipTests" so that the AMP will be built and added to your local Maven repo. Once you do that your workflow project should be able to build.