Indexing only works if I upload the file using Share GUI

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

Indexing only works if I upload the file using Share GUI

When uploading a file, I expect the content to be indexed so that I am able to search it. This works when I upload the file to the Alfresco Share interface.

However, when I use the CMIS import tool, webdav, or the bulk filing system, the metadata is indexed, but the content isn't. 

All the metadata looks the same. And even when I delete data from Solr to force a reindexing, the only content that is indexed is the content of the files I uploaded with Share GUI.

When I increase the Solr debug logging level (like this: https://docs.alfresco.com/5.2/tasks/set-solr-log4j.html), the logs of the files that were sent through the interface and indexed are the same as the logs of the files that were sent via WebDav and not indexed.
 
File indexed by the interface:
2020-02-21 21:36:40.251 DEBUG (org.alfresco.solr.AlfrescoCoreAdminHandler@548d708a_Worker-22) [   ] o.a.s.t.MetadataTracker Node [id=879, nodeRef=workspace://SpacesStore/a6ffb77b-7690-4f3f-8a73-074dc406bc46, txnId=27, status=UPDATED, tenant=, aclId=11, shardPropertyValue=null]
 
File sent via WebDav:
2020-02-21 21:39:10.113 DEBUG (org.alfresco.solr.AlfrescoCoreAdminHandler@548d708a_Worker-36) [   ] o.a.s.t.MetadataTracker Node [id=885, nodeRef=workspace://SpacesStore/f2510e59-43ca-41e2-899f-a574bea41222, txnId=33, status=UPDATED, tenant=, aclId=11, shardPropertyValue=null]
 
I couldn't find a solution to this issue.
This is easy to replicate with the docker community deployment in version 6.2.0-ga.
The log files also do not report any errors.
9 Replies
Highlighted
Member II

Re: Indexing only works if I upload the file using Share GUI

I have the same problem.

Can anyone help ?

Highlighted
Community Manager
Community Manager

Re: Indexing only works if I upload the file using Share GUI

Hi @marcoslessa & @Jhousyfran,

Could you tell us a little more about your environments please? This might help us determine if it's a bug or a configuration issue - or something else entirely!

Thanks,   

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!
Highlighted
Active Member

Re: Indexing only works if I upload the file using Share GUI


Operating System: Ubuntu 18.04

I'm using the container docker:
- Alfresco 5.2 Platform
- Alfresco Share 5.2
- Solr 6
- Postgres 9.4

###############################
## Common Alfresco Properties #
###############################

#
# Sample custom content and index data location
#
dir.root=/usr/local/alfresco/alf_data

alfresco.context=alfresco
alfresco.host=127.0.0.1
alfresco.port=8080
alfresco.protocol=http

share.context=share
share.host=127.0.0.1
share.port=8080
share.protocol=http

### database connection properties ###
db.driver=org.postgresql.Driver
db.username=alfresco
db.password=alfresco
db.name=alfresco
db.url=jdbc: postgresql://db:5432/${db.name}
db.pool.max=275
db.pool.validate.query=SELECT 1

# The server mode. Set value here
# UNKNOWN | TEST | BACKUP | PRODUCTION
system.serverMode=UNKNOWN

### FTP Server Configuration ###
ftp.enabled=false
ftp.port=2121

### CIFS Server Configuration ###
cifs.enabled=false

### RMI registry port for JMX ###
alfresco.rmi.services.port=50500

### External executable locations ###
ooo.exe=soffice.bin
ooo.host=libreoffice
ooo.enabled=true
ooo.port=8100
img.exe=/usr/bin/convert
alfresco-pdf-renderer.root=/usr/local/alfresco/alfresco-pdf-renderer
alfresco-pdf-renderer.exe=${alfresco-pdf-renderer.root}/alfresco-pdf-renderer
jodconverter.enabled=false
jodconverter.officeHome=/opt/libreoffice
jodconverter.portNumbers=8100

### E-mail site invitation setting ###
notification.email.siteinvite=false

### License location ###
dir.license.external=/usr/local/alfresco

### Allow extended ResultSet processing
security.anyDenyDenies=false

### Smart Folders Config Properties ###
smart.folders.enabled=false

### Remote JMX (Default: disabled) ###
alfresco.jmx.connector.enabled=false

### IMAP Server Configuration ###
imap.server.enabled=false

alfresco.rmi.services.host=0.0.0.0

#Smart Folders Config Properties
smart.folders.enabled=false
smart.folders.model=alfresco/model/smartfolder-model.xml
smart.folders.model.labels=alfresco/messages/smartfolder-model

### Solr indexing ###
index.subsystem.name=solr6
solr.host=solr6
solr.port=8983
solr.port.ssl=8443
solr.secureComms=none

## OCR
ocr.command=/usr/local/alfresco/ocr.sh
ocr.output.verbose=true
ocr.output.file.prefix.command=
ocr.extra.commands=
ocr.server.os=linux

## Audit Log
audit.enabled=true
audit.alfresco-access.enabled=true
audit.alfresco-access.sub-actions.enabled=false

## Aggregate Content Store
dir.contentstore1=${dir.root}/tier1
dir.contentstore2=${dir.root}/tier2
dir.contentstore3=${dir.root}/tier3

## S3 Store
# s3.bucketName=alfresco
# s3.bucketLocation=
# s3.accessKey=
# s3.secretKey=

## IMAP
imap.server.enabled=true
imap.server.port=9143
imap.server.attachments.extraction.enabled=true
# imap.server.host=mydomain.com.br
alfresco.protocol=https
alfresco.host=mydomain.com.br
alfresco.port=443

## FTP
ftp.enabled=true
ftp.port=9021

## CIFS
cifs.enabled=true
cifs.serverName=cifs
cifs.domain=mydomain.com.br
cifs.tcpipSMB.port=9445
cifs.netBIOSSMB.namePort=9137
cifs.netBIOSSMB.datagramPort=9138
cifs.netBIOSSMB.sessionPort=9139

Highlighted
Community Manager
Community Manager

Re: Indexing only works if I upload the file using Share GUI

Hi @Jhousyfran,

Thanks for the info update - I'll see if this helps us figure out what's going on. 

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!
Highlighted

Re: Indexing only works if I upload the file using Share GUI

The component tracking the content from Alfresco Repository is named Content Tracker. You can find details on the behaviour in https://hub.alfresco.com/t5/alfresco-content-services-blog/the-alfresco-content-tracker/ba-p/288185

Can you add DEBUG log for org.alfresco.solr.tracker.ContentTracker class to have additional information on this problem?

Software Engineer in Alfresco Search Team.
Highlighted
Active Member

Re: Indexing only works if I upload the file using Share GUI

Hello guys,
 
After hours of trying to make Webdav indexing work, I decided to install Alfresco on my personal computer, and to my surprise, it worked on there. And I didn't do anything differently from what I did on the server.

My personal computer's operating system is ubuntu 18.04, and the server I'm having a problem with is an image of the ubuntu 18.04 Server on AWS, I also started up a server with Ubuntu 18.04 Server on Digital Ocean and Webdav indexing didn't work.

Does anyone have any idea of what could be going on? The logs are the same, there are no errors.
Highlighted
Member II

Re: Indexing only works if I upload the file using Share GUI

up

Highlighted
Member II

Re: Indexing only works if I upload the file using Share GUI

Can anyone help us ?

Highlighted
Community Manager
Community Manager

Re: Indexing only works if I upload the file using Share GUI

Hi @marcoslessa & @Jhousyfran,

I'm asking around to see if we can progress this.

Cheers, 

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!