Installed the 6.0 Enterprise edition. It expired and reverted to the community edition. But the repo now starts in read-only mode. Did I do something to it (ran out of disk space once) or is that normal? Do I need to install a new community edition?

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Installed the 6.0 Enterprise edition. It expired and reverted to the community edition. But the repo now starts in read-only mode. Did I do something to it (ran out of disk space once) or is that normal? Do I need to install a new community edition?

I

4 Replies
Highlighted
Senior Member II

Re: Installed the 6.0 Enterprise edition. It expired and reverted to the community edition. But the repo now starts in read-only mode. Did I do something to it (ran out of disk space once) or is that normal? Do I need to install a new community edition?

cannot say for 6.0 Enterprise but - when the license of the enterprise edition expires, alfresco switches to read only mode. I have never recognized that it reverts to community edition. You should be able to feed your data and documents (migrate) to the community edition. See also Richard Esplin‌s article  

Highlighted
Professional

Re: Installed the 6.0 Enterprise edition. It expired and reverted to the community edition. But the repo now starts in read-only mode. Did I do something to it (ran out of disk space once) or is that normal? Do I need to install a new community edition?

I believe what you have now is Enterprise Edition in read-only mode, as Martin says. The login screen may show "Community Edition" but you don't have a functional Community Edition. That's just what happens to the login screen when the license expires.

If you are not going to renew your license, you're going to have to migrate to Community Edition.

To do that, you'll want your schemas to line up as closely as possible, or at least you'll want to move to a Community Edition version that has a slightly newer version if you cannot line them up exactly. The community maintains this page to help you do that alignment:  

Highlighted
Member II

Re: Installed the 6.0 Enterprise edition. It expired and reverted to the community edition. But the repo now starts in read-only mode. Did I do something to it (ran out of disk space once) or is that normal? Do I need to install a new community edition?

Thanks Jeff and Martin,

The Enterprise was just a PoC so I stopped that VM and installed the 5.2 Community on another VM. I tried the 6.0 Docker install but that was a mess, probably b/c I don't use docker much. Anyway, all seem to be good now or at least as good as it was before minus a couple of things the Enterprise version had. No worries on that though, it a learning experience...

Highlighted
Senior Member II

Re: Installed the 6.0 Enterprise edition. It expired and reverted to the community edition. But the repo now starts in read-only mode. Did I do something to it (ran out of disk space once) or is that normal? Do I need to install a new community edition?

Glad you made it.