Internal error. Failed to copy content to string

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Internal error. Failed to copy content to string

Hello,

After restarting my Alfresco Server I can do login and see my control panel perfectly. However, when I acces to a site appears this error message:

01140129 org.alfresco.service.cmr.repository.ContentIOException: 01140471 Failed to copy content to string:
    accessor: ContentAccessor[ contentUrl=store://2019/10/22/14/20/ea4237fa-e15c-43be-9a4e-7da13e5b5e9c.bin, mimetype=text/plain, size=0, encoding=UTF-8, locale=es_ES

And I can't do nothing. In others sites this message doesn't appears, but I can't see any file. The services have started correctly and I did a checkmysql in Alfresco's DB without detect any issue. If I access trough WEBDAV I can see all my files correctly.

I running Alfresco 6.0 with Ubuntu 14.04 and Mysql 5.5

Thanks in advanced

 

2 Replies
Highlighted
Master

Re: Internal error. Failed to copy content to string

You only provided a part of the error message without any context / thread dump, to actually see where the problem occurs. From that it looks like some file that should exist in your contentstore structure is either missing or empty, and as such cannot be read. That file is likely one of the configuration files that Alfresco manages in the background for your site, and if it can't be read, Alfresco lacks the information to properly display the site dashboard / other elements of the site.

This issue may not have anything to do with your database, as long as the database is set up correctly to properly handle transactions (e.g. in MySQL you should use InnoDB instead of MyISAM). You should check your content store for a file in the path 2019/10/22/14/20/ea4237fa-e15c-43be-9a4e-7da13e5b5e9c.bin. If that does not exist or is 0-bytes of size, check your contentstore.deleted for the same path, and if you find a file there, move it over/back into the regular content store. This might fix your issue if you can find that file. If you have backups of your content store, you may also want to check these for that file and restore it if found.

Highlighted
Member II

Re: Internal error. Failed to copy content to string

Hello afaust.

First of all, thanks for your help. It's weird, because I restored some of my backups of my Alfresco's VM with the same result. So, I think that is problem of my NFS shared folder mounted in /opt/alfresco/alfdata. However, I tried also to restore that file in other older versions without luck; the same error appears.

Its a pity because my Alfresco runs OK but it cannot load the library of oll my different sites. I only turned off the VM for cluster maintenance and when I turned it on this error appeared.

My version it's Alfresco Community v6.0.7 and it's run on Ubuntu 14 through Hyper-V virtualization.

If you need any test, logs or whatever just comment it.

Thanks in advanced.

David.