Is it possible to install addons on the community edition ? or not ?

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Is it possible to install addons on the community edition ? or not ?

Everything is in the tittle, each time I try to install addons it doesn't work ...

4 Replies
Highlighted
Master

Re: Is it possible to install addons on the community edition ? or not ?

A short reply for a short answer: Yes, it is possible to install addons.

Now, if you had created a question about specific problems with specific addons, maybe someone in the community could help identify the problem. I guess that would be more helpful to you then to simply repeat what the product marketing states about being able to install addons.

Highlighted
Member II

Re: Is it possible to install addons on the community edition ? or not ?

I'm trying to install pdf rendering from formtek, in order to see dwg files in alfresco, 

on the Alfresco addons site, it is written that it works with Alfresco 5.0 community edition :

Formtek PDF rendering

When I'm reading the step by step installation document, it is written that you need Alfresco one ... 

when I install it I got this issue : Question but nobody answer

so I was wondering if it works or not on Alfresco comuniuty edition in order to know if I have to pass more time on it or not ...

After that I tried to install Ephesoft and I success even if it was really verry hard to install, then I thougth that I could finally start to learn how to use it but that was a sweet dream ! I tried to follow some tutorial in order to integer it on Alfresco but nothing works. So basically, after days trying to make it works, being crazy more and more everry day, with a lots of VMs installation in order to go back if something break, I started to wonder if this is even possible...

Highlighted
Master

Re: Is it possible to install addons on the community edition ? or not ?

Did you also contact the vendor / developer directly? If there is any problem with an addon, it is best to contact the source first before coming to the general community.

From the documentation it looks like the PDF Rendering module comes with separate repository AMPs for Linux and Windows? Did you use the one that corresponds to your platform? Based on the install guide there are some changes to be made to environment variables - did you apply them? It looks like they have some custom, non-standard access to the the ImageMagick library - maybe it just does not work with the version of ImageMagick you have installed...

Highlighted
Member II

Re: Is it possible to install addons on the community edition ? or not ?

I have contact the developper directly, in fact this module is only available for Alfresco 5.0, I thought it was the latest release but I've installed the 5.2, that's why it doesn't work. then, I'm thinking about installing Alfreco 5.0 which is 2 year old ... in order to install this module or install alfresco-vector-transformation module which seems to work on alfresco 5.2

thx for ur reply !