Issue migration 5.0.4 vers 5.0.5

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

Issue migration 5.0.4 vers 5.0.5

Bonjour,

Quand je lance tomcat, je reçois ces erreurs dans log alfresco:

org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'publicApiCMISServiceFactory' defined in class path resource [alfresco/public-rest-context.xml]: Error setting property values; nested exception is org.springframework.beans.NotWritablePropertyException: Invalid property 'memoryThreshold' of bean class [org.alfresco.opencmis.PublicApiAlfrescoCmisServiceFactory]: Bean property 'memoryThreshold' is not writable or has an invalid setter method. Does the parameter type of the setter match the return type of the getter?

Caused by: org.springframework.beans.NotWritablePropertyException: Invalid property 'memoryThreshold' of bean class [org.alfresco.opencmis.PublicApiAlfrescoCmisServiceFactory]: Bean property 'memoryThreshold' is not writable or has an invalid setter method. Does the parameter type of the setter match the return type of the getter?

 

Merci d'avance

2 Replies
Highlighted
Intermediate II

Re: Issue migration 5.0.4 vers 5.0.5


It seems it is a bug of ver 5.0.5  ,you can try to upgrade to a Generally Available release version ,for example 5.2
About 5.2 GA please refer to
 https://hub.alfresco.com/t5/alfresco-content-services-hub/alfresco-community-edition-201702-ga-relea...

Highlighted
Active Member

Re: Issue migration 5.0.4 vers 5.0.5

Merci pour votre retour,

Alfresco vierge 5.0.5 se lance bien mais quand j'ai mis mon war ça marche pas.

pour information ce war execute bien dans la version 5.0.4.

il y a pas une solution à faire pour rester à utiliser la version 5.0.5 ?