Ldap problem alfresco community 5.2

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member II

Ldap problem alfresco community 5.2

Bonjour tout le monde !

Hello everyone ! (english version of my problem below)

Alors je pose une question ici car j'ai un souci avec la mise en place de l'AD sur alfresco community 5.2. Ayant cherché la doc et des réponses sur les forums, je viens ici après ne pas avoir réussi à le mettre en place.

Donc dans les forums j'ai vu que pour mettre en place l'ad il suffisait de rajouter ces lignes dans alfresco-global.properties :

authentication.chain=alfinst:alfrescoNtlm,ldap1:ldap-ad

ntlm.authentication.sso.enabled=false

ldap.authentication.allowGuestLogin=false
ldap.authentication.userNameFormat=%s@[nom-du-domaine]
ldap.authentication.java.naming.provider.url=ldap://[ip du serveur ldap]:389
ldap.authentication.defaultAdministratorUserNames= [noms des comptes à definir en tant qu'admin]
ldap.synchronization.java.naming.security.principal=WEBINFO@solicia.fr (user que j'ai créé pour alfresco)
ldap.synchronization.java.naming.security.credentials=mdp du compte ci-dessus
ldap.synchronization.groupSearchBase=ou=Solicia,dc=solicia,dc=fr (dans mon cas)

ldap.synchronization.userSearchBase=ou=Solicia,dc=solicia,dc=fr (dans mon cas)

malgré ça, après le redémarrage de mon serveur tomcat, alfresco ne prend toujours pas en compte l'ad ...

Ai-je loupé une étape ou ai-je mal configuré le fichier alfresco-global.properties ?

Merci par avance de votre aide !

William.

[English version]

So I came here because I got some problems with setting up AD on alfresco community 5.2. Founding any good documentation for that wasn't easy so I searched all the answers on forums. The thing is I still didn't make it :/

So in forums people told that I had to add these lines to turn on ad on  alfresco :

authentication.chain=alfinst:alfrescoNtlm,ldap1:ldap-ad

ntlm.authentication.sso.enabled=false

ldap.authentication.allowGuestLogin=false
ldap.authentication.userNameFormat=%s@[domain-name]
ldap.authentication.java.naming.provider.url=ldap://[server ad ip's]:389
ldap.authentication.defaultAdministratorUserNames= [accounts name that I want as admin]
ldap.synchronization.java.naming.security.principal=WEBINFO@solicia.fr (user I created for alfresco)
ldap.synchronization.java.naming.security.credentials=[password for the account WEBINFO)
ldap.synchronization.groupSearchBase=ou=Solicia,dc=solicia,dc=fr (in my case)

ldap.synchronization.userSearchBase=ou=Solicia,dc=solicia,dc=fr (in my case)

Even after restarting tomcat server's the AD function isn't working so I don't know if the problem comes from something I forgot or I made some mistakes in my config file :/

Thank you for the help,

William.

2 Replies
Highlighted
Advanced II

Re: Ldap problem alfresco community 5.2

Double post  

Highlighted
Active Member II

Re: Ldap problem alfresco community 5.2

Yeah sorry, I didn't know where to put it :/ I answered you on the other post