maven 3.5 error when execute run.bat in alfresco maven projet

cancel
Showing results for 
Search instead for 
Did you mean: 
Member II

maven 3.5 error when execute run.bat in alfresco maven projet

following this tutorial http://ecmarchitect.com/alfresco-developer-series-tutorials/maven-sdk/tutorial/tutorial.html of jpotts. i have the following problem runing the run.bat file.

[ERROR] Failed to execute goal org.alfresco.maven.plugin:alfresco-maven-plugin:3
.0.0:run (default-cli) on project someco-mvn-tutorial-repo: Unable to execute mo
jo: java.lang.reflect.InvocationTargetException: Invalid plugin descriptor for o
rg.apache.tomcat.maven:tomcat7-maven-plugin:2.2 (C:\Users\wt.m2\repository\org
apache\tomcat\maven\tomcat7-maven-plugin\2.2\tomcat7-maven-plugin-2.2.jar), Plug
in's descriptor contains the wrong group ID: org.apache.axis2, Plugin's descript
or contains the wrong artifact ID: axis2-ant-plugin, Plugin's descriptor contain
s the wrong version: 1.4 -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e swit
ch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please rea
d the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionE
xception
java.lang.NoClassDefFoundError: de/schlichtherle/truezip/fs/FsLockController$1Sy
nc
at de.schlichtherle.truezip.fs.FsLockController.sync(FsLockController.ja
va:240)
at de.schlichtherle.truezip.fs.archive.zip.KeyController.sync(KeyControl
ler.java:128)
at de.schlichtherle.truezip.fs.FsDecoratingController.sync(FsDecoratingC
ontroller.java:131)
at de.schlichtherle.truezip.fs.FsFalsePositiveArchiveController.sync(FsF
alsePositiveArchiveController.java:480)
at de.schlichtherle.truezip.fs.FsManager.sync(FsManager.java:105)
at de.schlichtherle.truezip.fs.FsDefaultManager.sync(FsDefaultManager.ja
va:190)
at de.schlichtherle.truezip.fs.FsSyncShutdownHook$Hook.run(FsSyncShutdow
nHook.java:93)
Caused by: java.lang.ClassNotFoundException: de.schlichtherle.truezip.fs.FsLockC
ontroller$1Sync
at org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(
SelfFirstStrategy.java:50)
at org.codehaus.plexus.classworlds.realm.ClassRealm.unsynchronizedLoadCl
ass(ClassRealm.java:271)
at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm
.java:247)
at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm
.java:239)
... 7 more

  • Maven 3.5
  • alfresco-platform-jar-archetype version with SDK 3.0.0-beta-5. Also not working with SDK 3.0.0

NEED HELP

1 Reply
Senior Member II

Re: maven 3.5 error when execute run.bat in alfresco maven projet

It seems like you have some corrupted jar which is causing this issue.Try to remove .m2 directory or rename it and download fresh dependencies.