Maven Dependency Issue

cancel
Showing results for 
Search instead for 
Did you mean: 
Active Member

Maven Dependency Issue

I have seen a project done with alfresco 4.2 in github, I downloaded and try to run in my system to see how its working, I failed to build the project. I can't able find the dependencies for two jars.

Could anyone tell me what i need to do to run this project in my local system.

console :

[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Build Order:
[INFO]
[INFO] [parent] fme Alfresco Extended Datalists
[INFO] fme Alfresco Extended Datalists Repo
[INFO] fme Alfresco Extended Datalists Share
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building [parent] fme Alfresco Extended Datalists 1.3.2
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ fme-alfresco-extdl-parent ---
[INFO]
[INFO] --- maven-install-plugin:2.4:install (default-install) @ fme-alfresco-extdl-parent ---
[INFO] Installing D:\spring tool suite - workspace\fme-alfresco-extdl-master\pom.xml to C:\Users\DELL\.m2\repository\de\fme\fme-alfresco-extdl-parent\1.3.2\fme-alfresco-extdl-parent-1.3.2.pom
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building fme Alfresco Extended Datalists Repo 1.3.2
[INFO] ------------------------------------------------------------------------
[WARNING] The POM for org.springframework.extensions.surf:spring-webscripts:jar:1.2.0-SNAPSHOT is missing, no dependency information available
[WARNING] The POM for org.springframework.extensions.surf:spring-webscripts-api:jar:1.2.0-SNAPSHOT is missing, no dependency information available
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
[INFO] [parent] fme Alfresco Extended Datalists ........... SUCCESS [ 0.682 s]
[INFO] fme Alfresco Extended Datalists Repo ............... FAILURE [ 1.277 s]
[INFO] fme Alfresco Extended Datalists Share .............. SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2.100 s
[INFO] Finished at: 2017-11-16T11:32:00+05:30
[INFO] Final Memory: 13M/224M
[INFO] ------------------------------------------------------------------------
[WARNING] The requested profile "run" could not be activated because it does not exist.
[ERROR] Failed to execute goal on project fme-alfresco-extdl-repo: Could not resolve dependencies for project de.fme:fme-alfresco-extdl-repo:jar:1.3.2: The following artifacts could not be resolved: org.springframework.extensions.surf:spring-webscripts:jar:1.2.0-SNAPSHOT, org.springframework.extensions.surf:spring-webscripts-api:jar:1.2.0-SNAPSHOT: Failure to find org.springframework.extensions.surf:spring-webscripts:jar:1.2.0-SNAPSHOT in https://artifacts.alfresco.com/nexus/content/groups/public was cached in the local repository, resolution will not be reattempted until the update interval of alfresco-public has elapsed or updates are forced -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException
[ERROR]
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR] mvn <goals> -rf :fme-alfresco-extdl-repo

3 Replies
Senior Member II

Re: Maven Dependency Issue

As this is 4.2 version I suspect that this version of jar are not available in the repository.I think you should convert this project in to the version which you are using.

I have used this previously by copying the files in to the latest maven project.

Active Member

Re: Maven Dependency Issue

Currently, I have using alfresco 5.2 and I created a project with SDK 2.2, can i copy the files into my project?

And what about dependencies, I need to copy the dependencies related to this project into my one or I can download the dependencies there in my project.

Senior Member II

Re: Maven Dependency Issue

Basically if its an external dependancy than you need to copy it, For example apache poi might not be available in alfresco sdk 2.2.

You will get an idea of this stuff once you copy the java files in new project.

As per my knowledge , there might be 1-2 dependencies which you need to copy(like apache poi).