Migration new theme from sdk 2 to sdk 3.0.1

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Established Member II

Migration new theme from sdk 2 to sdk 3.0.1

Hi,

i have succed to add a new theme with alfresco sdk 2.

i need to upgrade to sdk 3.0.1

I understand (but i may be wrong) that  src/main/amp/web directory of my sdk 2 project, moves to src/main/assembly/web directory of my project-share-jar :

But what about src/main/amp/config ? 

I have updated share-jar pom file like this :

and platform-jar like this :

but i'm not sure it's right.

Thx in advance for your help !

9 Replies
Highlighted
Advanced II

Re: Migration new theme from sdk 2 to sdk 3.0.1

The src/main/amp/config is the equivalent to src/main/resources

Highlighted
Established Member II

Re: Migration new theme from sdk 2 to sdk 3.0.1

Hi,

thank you for your answer.

I did it but it doesnt work. I think ithe poblem is in my POM files but i don't find.

And what about project/runner/tomcat/context-share.xml ? (Runner module doesn't exist anymore with SDK 3)

Adding a custom Share Theme | Alfresco Documentation 

Thx

Highlighted
Advanced II

Re: Migration new theme from sdk 2 to sdk 3.0.1

Using SDK 3.0, you don't have to configure the overlays.

All you have to do is to include a moduleDependency, as you already did.

Try this... add the parameter <type>amp</type> inside of your moduleDependency.

Highlighted
Established Member II

Re: Migration new  theme from sdk 2 to sdk 3.0.1

It doesn't work BUT after reading this doc (Working with AMPs | Alfresco Documentation ) and my main POM.xml, i think i was wrong.

So this is what i have done :

- In my platform-jar and share-jar POM files : i have deleted all my modifications in <build> section   (as if i start a new AIO sdk3 project).

- In my main POM file i have uncommented the plugin section about "maven-assembly-plugin".

- In my main POM file in <shareModules> section i have added <type>amp</type> as you ask me, and i have added another <moduleDependency> for Javascript Console like mentioned in the doc.

It doesn't still work BUT it's in progress :-)

I find my custom theme in Tomcat ! 

I think it's a config issue .

The config folder is in src/main/resources folder.

After reading README.md file located in src/main/assembly/web folder, i move config folder in /src/main/resources/META-INF/resources/klinck-share-jar/ l.

But without success.

Thx in advance

 

Highlighted
Advanced II

Re: Migration new theme from sdk 2 to sdk 3.0.1

Well, it seems you are doing everything right, but when you say it does not work, what do you mean?

Do you see your client side files deployed?

Is there any error message in the logs?

It is starting to be hard to help you without "seeing" what you are doing.

Is there any chance you can share your project?

Highlighted
Established Member II

Re: Migration new theme from sdk 2 to sdk 3.0.1

Shame on me ! i have added files instead of update present files ... All is OK !

Highlighted
Established Member II

Re: Migration new theme from sdk 2 to sdk 3.0.1

Hi,

sorry, i got an issue with images content. When i choose my custom theme i don't see logo on the site page, login page etc...

I don't have this problem with other standard theme.

I found this page :

Images (png/ico/jpg) from share assembly/web corrupted when copied to target/share-war · Issue #468 ... 

and so i update my amp.xml like this :

I didn't change file-mapping.properties

Thx for your help

Highlighted
Advanced II

Re: Migration new theme from sdk 2 to sdk 3.0.1

That is how I fixed it.

Have you tried to clean the browser cache?

Highlighted
Established Member II

Re: Migration new theme from sdk 2 to sdk 3.0.1

Well done !! Thank you !!