Missing Folder in Webdav

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Missing Folder in Webdav

Using the Webfrontend I can see a folder, however using Webdav it will not show up

e.g. in https://[OurSite]/alfresco/webdav/ it will not be listed

but typing in following in a browser will list its content 

https://[OurSite]/alfresco/webdav/[missingFolder]
https://[OurSite]/alfresco/aos/[missingFolder]

Mapping also doesn't work quite right on a Windows 10 pc:
https://[OurSite]/alfresco/webdav/  --> works but the single Folder is not listed
https://[OurSite]/alfresco/webdav/[missingFolder]  --> doesn't work, it cant find the folder
https://[OurSite]/alfresco/aos/[missingFolder]  --> kinda works, it will list the contents but uploading files generates error messages

As far as I know the admin deleted the folder by accident and restored it but ever since it won't show up. Any ideas where to begin troubleshooting? Thank you

1 Reply
Highlighted
Moderator
Moderator

Re: Missing Folder in Webdav

On windows 10, i could not replicate the issue you have mentioned. i tried deleting folders via share and restore them back, i could see and navigate the items in the folder via webdav after restoration. 

I tried deleting the folder from webdav interface and restored it back via webdav. I could see and navigate the folder and its content via both share and webdav. 

I did noticed that, when i restored the folder via Share and tried to access the folder via webdav, it was not clickable immediately and took few seconds to a minute to allow navigating the folder again. But i was not able to replicate the visibilty issue at all. 

Can you try investigagting the restored folder nodeRef via node browser and see if you can notice any thing special there? Also just try updating some properties of the folder via share and see if it starts showing 

 

Documentation for troubleshooting, just in case: https://docs.alfresco.com/5.2/concepts/troubleshoot-webdav.html

~Abhinav
(ACSCE, AWS SAA-C02)
https://javaworld-abhinav.blogspot.com