New Alfresco install warning message

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

New Alfresco install warning message

I'm first-time installing Alfresco ECM CE 5.2.2 on Ubuntu 1404 and I'm getting the following never-ending message:

Some or all of the libraries needed to support LibreOffice were not found on your system: fontconfig libSM libICE libXrender libXext libcups libGLU libcairo2 libgl1-mesa-glx
You are strongly advised to stop this installation and install the libraries.
For more information, see the LibreOffice documentation at http://docs.alfresco.com/search/site/all?keys=libfontconfig

Since my distro doesn't contain those specific versions, I installed the following: 

"libfontconfig libSM6 libICE6 libXrender1 libXext6 libcups2 libGLU1-mesa"

"libcairo2 libgl1-mesa-glx" were the only packages I didn't need to worry about.

I'm considering filing a bug report. What am I missing?

4 Replies
Highlighted
Customer

Re: New Alfresco install warning message

This error is somehow usual. 

In Ubuntu the package names are slightly different, try for example:

sudo apt-get install libfontconfig1 libice6 libsm6 libxrender1 libxext6 libxinerama1 libcups2 libglu1-mesa libcairo2 libgl1-mesa-glx

The key is that, once Alfresco is started, Libreoffice process can start without problems.

Regards.

--C.

Highlighted
Active Member

Re: New Alfresco install warning message

Hi Cesar,

Thanks for the response. No change. Still same message. I'll ignore it for now.

Sincerely,

PS: Something to point out to people with the same issue, there's a list of supported platforms for Alfresco 5.2.2 I found here. I haven't tried Ubuntu 1604 yet.

Highlighted
Master

Re: New Alfresco install warning message

Note: There is no community edition (CE) version called 5.2.2. That "5.2.2" version is the enterprise edition (EE) of Alfresco, also called Alfresco Content Services. The latest CE version is 201707 GA (release bundle name as found on this platform), comprised of Alfresco Platform 5.2.g and Alfresco Share 5.2.f.

Highlighted
Customer

Re: New Alfresco install warning message

Hi:

I mean that, you can skip this pass and ignore this message by the moment. But you need these libraries for Libreoffice, so install them via apt.

Then you have to be sure that Libreoffice's transformations are working properly (for example when previewing a doc file in Alfresco Share). A previous basic check is to run $ALF_HOME/libreoffice/program/bin/soffice.bin --help in a terminal. If no problems are obtained with dependencies, you are going in the right way.

Regards.

--C.