No appenders could be found for logger (aoservices-trc.AbstractVermeerService)

cancel
Showing results for 
Search instead for 
Did you mean: 
Active Member II

No appenders could be found for logger (aoservices-trc.AbstractVermeerService)

Hi !!

When i try to edit any document in Word or any item for MS office, i cant save it...

I have the following message: Load failed; unfortunately this did not work. Try again save, if it still doesn't work, click save a copy;

In logs files, is it the output:

2020-11-12 15:58:59,890 INFO [web.scripts.DictionaryQuery] [http-apr-8080-exec-8] Successfully retrieved Data Dictionary from Alfresco.
2020-11-12 15:59:04,152 INFO [web.scripts.QuickShareStatus] [http-apr-8080-exec-4] Successfully retrieved quick share information from Alfresco.
2020-11-12 15:59:05,454 INFO [web.scripts.MimetypesQuery] [http-apr-8080-exec-8] Successfully retrieved mimetypes information from Alfresco.
log4j:WARN No appenders could be found for logger (aoservices-trc.AbstractVermeerService).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.

Libreoffice already running....

Anyone can help? 

 

3 Replies
Moderator
Moderator

Re: No appenders could be found for logger (aoservices-trc.AbstractVermeerService)

Can you confirm how you installed acs ? did you installed manually using distribution or used dokcer based deployment. As per pre-requsites SSL must be enabled in order to use AOS version 1.1.x and onwards. Latest docker-compose.yml comes with AOS 1.3.x out of the box installed within acs image.

Libreoffice is not a dependency for AOS as far as i know, you should have "_vti_bin and ROOT" apps installed. 

Have a look at this documentation: 

https://docs.alfresco.com/aos1.1/concepts/aos-prereqs.html

https://docs.alfresco.com/aos1.1/tasks/install-server-root.html

https://docs.alfresco.com/aos1.1/concepts/aos-issues.html

In addition, if you have installed everything correctly, try adding following debug logs and see what you get:

log4j.logger.org.alfresco.module.aosmodule=DEBUG
log4j.logger.org.alfresco.officeservices=DEBUG
~Abhinav
(ACSCE, AWS SAA-C02, GAIQ)
Active Member II

Re: No appenders could be found for logger (aoservices-trc.AbstractVermeerService)

Thnks for reply

i install manually using the version 6.0.2 (Alfresco Community Early Access v6.0.2(r9a538671-b197) schema 10201) and using nginx for final proxy with SSL certifed 

i'll add this parameters for debug log.

Active Member II

Re: No appenders could be found for logger (aoservices-trc.AbstractVermeerService)

I gotcha it....

I att the alfresco-aos-module for version 1.2.0 and _vti_bin.war, and it works ( i'm testing yet, but at moment its works fine...)

 

but in log log4j for content transform ( preview) i have it:

2020-11-12 18:47:21,479 INFO [management.subsystems.ChildApplicationContextFactory] [http-apr-8080-exec-9] Starting 'Transformers' subsystem, ID: [Transformers, default]
2020-11-12 18:47:21,649 INFO [management.subsystems.ChildApplicationContextFactory] [http-apr-8080-exec-9] Startup of 'Transformers' subsystem, ID: [Transformers, default] complete
2020-11-12 18:47:35,597 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1 docx jpg PTRFJanauba_Ver02_Continental.docx 5.4 MB -- imgpreview -- ContentService.transform(...)
2020-11-12 18:47:35,787 INFO [web.scripts.MimetypesQuery] [http-apr-8080-exec-4] Successfully retrieved mimetypes information from Alfresco.
2020-11-12 18:47:36,766 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1 workspace://SpacesStore/74338e7d-2a0b-4b6b-8a26-2115534989eb
2020-11-12 18:47:36,769 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1 **a) [100] OOXMLThumbnail 0 ms
2020-11-12 18:47:36,769 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1 b) [250] complex.JodConverter.Image<<Complex>> 0 ms
2020-11-12 18:47:36,772 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1 c) [400] complex.Any.Image<<Complex>> 0 ms
2020-11-12 18:47:36,773 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.1 docx jpg PTRFJanauba_Ver02_Continental.docx 5.4 MB OOXMLThumbnail
2020-11-12 18:47:37,951 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.1 Failed 10120021 No thumbnail present in file, unable to generate image/jpeg
2020-11-12 18:47:37,954 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1
2020-11-12 18:47:37,955 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1 Try b)
2020-11-12 18:47:37,955 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.2 docx jpg PTRFJanauba_Ver02_Continental.docx 5.4 MB complex.JodConverter.Image<<Complex>>
2020-11-12 18:47:37,974 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.2.1 docx pdf PTRFJanauba_Ver02_Continental.docx 5.4 MB JodConverter.2Pdf<<FailoverComponent>>
2020-11-12 18:47:37,981 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.2.1 No more transformations to failover to
2020-11-12 18:47:37,981 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.2.1 Failed 10120023 Unsupported transformation: application/vnd.openxmlformats-officedocument.wordprocessingml.document to application/pdf
2020-11-12 18:47:37,982 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.2 Failed 10120023 Unsupported transformation: application/vnd.openxmlformats-officedocument.wordprocessingml.document to application/pdf
2020-11-12 18:47:37,983 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1
2020-11-12 18:47:37,983 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1 Try c)
2020-11-12 18:47:37,984 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.3 docx jpg PTRFJanauba_Ver02_Continental.docx 5.4 MB complex.Any.Image<<Complex>>
2020-11-12 18:47:37,996 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.3.1 docx jpg PTRFJanauba_Ver02_Continental.docx 5.4 MB ContentService.transform(...)
2020-11-12 18:47:37,997 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.3.1 **a) [100] OOXMLThumbnail 120,000 ms
2020-11-12 18:47:37,997 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.3.1 b) [250] complex.JodConverter.Image<<Complex>> 0 ms
2020-11-12 18:47:37,998 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.3.1.1 docx jpg PTRFJanauba_Ver02_Continental.docx 5.4 MB OOXMLThumbnail
2020-11-12 18:47:43,087 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.3.1.1 Failed 10120025 No thumbnail present in file, unable to generate image/jpeg
2020-11-12 18:47:43,088 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.3.1
2020-11-12 18:47:43,088 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.3.1 Try b)
2020-11-12 18:47:43,089 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.3.1.2 docx jpg PTRFJanauba_Ver02_Continental.docx 5.4 MB complex.JodConverter.Image<<Complex>>
2020-11-12 18:47:43,090 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.3.1.2.1 docx pdf PTRFJanauba_Ver02_Continental.docx 5.4 MB JodConverter.2Pdf<<FailoverComponent>>
2020-11-12 18:47:43,090 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.3.1.2.1 No more transformations to failover to
2020-11-12 18:47:43,090 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.3.1.2.1 Failed 10120027 Unsupported transformation: application/vnd.openxmlformats-officedocument.wordprocessingml.document to application/pdf
2020-11-12 18:47:43,091 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.3.1.2 Failed 10120027 Unsupported transformation: application/vnd.openxmlformats-officedocument.wordprocessingml.document to application/pdf
2020-11-12 18:47:43,102 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1.3 Failed 10120026 Content conversion failed
2020-11-12 18:47:43,104 DEBUG [content.transform.TransformerDebug] [pool-14-thread-1] 1 Finished in 7,509 ms