opencmis.maxContentSize parameter is not working

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member II

opencmis.maxContentSize parameter is not working

Hi, 

Because of performance issues we are experimenting in our Alfresco 5, we are trying to limit the size of the files that can be synchronized using CmisSync. To do so, I'm following the steps that are indicated here: CMIS configuration settings | Alfresco Documentation 

So, I've added in alfresco-global.properties file this piece of code: 

opencmis.maxContentSize=100

Once this is done, I've restarted Alfresco and uploaded to the folder CMisSync synchronizes with some files whose size is more than 100MB, and what I have expected is not seeing those files in Alfresco, given that their size is higher than 100MB. However, I'm seeing them. 

Anyone could help me? What's happening?

Thanks in advance. Regards. 

5 Replies
Highlighted
Active Member II

Re: opencmis.maxContentSize parameter is not working

I add that, in addition to previous comment, the changes I'm making to limit upload size, as indicated here: Module dynamic configuration | Alfresco Documentation  are also not taking effect after restarting Alfresco.

Highlighted
Senior Member

Re: opencmis.maxContentSize parameter is not working

Hi,


Maybe you could try this (alfresco-global.properties):

system.content.maximumFileSizeLimit=xxxx bytes 

Regards,
clv

Highlighted
Active Member II

Re: opencmis.maxContentSize parameter is not working

Hi José Ángel, 

Thanks for your answer. In fact, it has been useful to limit the size of the uploaded files via Alfresco graphical interface, but, despite this, this parameter is not been taking into account when synchronizing files from a folder in my computer through CmisSync Smiley Sad

Highlighted
Member II

Re: opencmis.maxContentSize parameter is not working

Hello, 

I've had the same problem and I had to go through Alfresco code. The problem is that the documentation is wrong: documentation cmis

Fortunately it was just a flag probleam. Its name was changed and you should use this one: 

opencmis.maxContentSizeMB=

instead of the one indicated in the page:

opencmis.maxContentSize=

Best Regards,

Highlighted
Alfresco Employee

Re: opencmis.maxContentSize parameter is not working

Hi @brunobottazzini 

Thanks for pointing out the problem with the documentation. This has now been fixed in CMIS configuration settings | Alfresco Documentation. 

 

@chortels If your issue was been resolved, please click "Accept as Solution" to promote the solution to the rest of the Community. Many thanks Smiley Happy 

Technical Writer in Alfresco User Assistance Team
Problem solved? Click Accept as Solution!