Problems with query string length

cancel
Showing results for 
Search instead for 
Did you mean: 
Member II

Problems with query string length

I seem to run in a problem with the query string length (this is at least my assumption based on observations).

The project uses a complex advanced search form with lots of fields. Doing a search normally works fine. But when either a couple of long strings are filled out in the form or a couple of filters are applied in the facted search, the search fails. Error message is (maybe not exactly - this is a German Alfresco installation): "There was an error requesting your search results. Please try again." 

When analyzing this,  I took a look at the long query string and tried to shorten it - as soon as the length was below 4120 characters, the queries worked, no matter if I removed attributes completely or shortened some search strings.

I did not see any errors in the alfresco.log or catalina.out or solr.log.

Any advice? Is there any way to extend this limit?

As normally only a subset of the fields in the advanced search form will be used, another option would be to optimize the query string before sending out the advanced search. Many fields in the query string are unused parts like "attributename":""

Where would be the right extension point to modify this before it is processed?

Alfresco Version is latest 5.x Community.

Thanks for any input!
Chris

1 Reply
Senior Member

Re: Problems with query string length

Hi

I suspect either your allowed URL length is really too short or this is a known issue with sharding- [SEARCH-561] Sharding restricts the number of results / "allowed" page sizes - Alfresco JIRA.

If you are only allowing 4120 characters on your URL this need to go up. Our default is much higher.

If you are using SOLR 4/6 sharding you may need to set the header size somewhat higher.

Andy