Problems with SOLR and Login in share

cancel
Showing results for 
Search instead for 
Did you mean: 
Active Member II

Problems with SOLR and Login in share

Jump to solution

Using default username and password, as saved in mysql database, I try to login on to /share.

The only thing I get is a message telling me that my credentials are wrong or that alfresco is not running. I checked in /manager where I see that all webapps are running. On /alfresco I get a standard website with links but no login window.

The most confusing thing is that I see nothing in my logs during login. Neither in:

  •  /var/log/alfresco/catalina.out
  •  /usr/local/alfresco-5.0.d/alfresco.log
  •  /usr/local/alfresco-5.0.d/solr.log
  • /usr/local/alfresco-5.0.d/share.log

Share, Alfresco and Mysql all run on the same mache. In alfresco-global.properties I have:

alfresco.context=alfresco
alfresco.host=intranet-test.snct.lux
alfresco.port=8080
alfresco.protocol=http

share.context=share
share.host=intranet-test.snct.lux
share.port=8080
share.protocol=http

When I do a reload in /manager or /share of the /alfresco app, I get no errors in the logs either.

When I reload /solr4 I get

2017-07-24 10:02:14,871  ERROR [solr.core.CoreContainer] [coreLoadExecutor-5-thread-1] Unable to create core: collection1
 org.apache.solr.common.SolrException: Could not load core configuration for core collection1
        at org.apache.solr.core.ConfigSetService.getConfig(ConfigSetService.java:66)
        at org.apache.solr.core.CoreContainer.create(CoreContainer.java:554)
        at org.apache.solr.core.CoreContainer$1.call(CoreContainer.java:261)
        at org.apache.solr.core.CoreContainer$1.call(CoreContainer.java:253)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)
Caused by: org.apache.solr.common.SolrException: Error loading solr config from solr/collection1/solrconfig.xml
        at org.apache.solr.core.SolrConfig.readFromResourceLoader(SolrConfig.java:148)
        at org.apache.solr.core.ConfigSetService.createSolrConfig(ConfigSetService.java:79)
        at org.apache.solr.core.ConfigSetService.getConfig(ConfigSetService.java:61)
        ... 9 more
Caused by: java.io.IOException: Can't find resource 'solrconfig.xml' in classpath or '/usr/local/alfresco-5.0.d/solr/collection1/conf'
        at org.apache.solr.core.SolrResourceLoader.openResource(SolrResourceLoader.java:362)
        at org.apache.solr.core.SolrResourceLoader.openConfig(SolrResourceLoader.java:308)
        at org.apache.solr.core.Config.<init>(Config.java:116)
        at org.apache.solr.core.Config.<init>(Config.java:86)
        at org.apache.solr.core.SolrConfig.<init>(SolrConfig.java:161)
        at org.apache.solr.core.SolrConfig.readFromResourceLoader(SolrConfig.java:144)
        ... 11 more
2017-07-24 10:02:14,874  ERROR [solr.core.CoreContainer] [coreLoadExecutor-5-thread-1] nullSmiley Surprisedrg.apache.solr.common.SolrException: Unable to create core: collection1
        at org.apache.solr.core.CoreContainer.recordAndThrow(CoreContainer.java:911)
        at org.apache.solr.core.CoreContainer.create(CoreContainer.java:568)
        at org.apache.solr.core.CoreContainer$1.call(CoreContainer.java:261)
        at org.apache.solr.core.CoreContainer$1.call(CoreContainer.java:253)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)
Caused by: org.apache.solr.common.SolrException: Could not load core configuration for core collection1
        at org.apache.solr.core.ConfigSetService.getConfig(ConfigSetService.java:66)
        at org.apache.solr.core.CoreContainer.create(CoreContainer.java:554)
        ... 8 more
Caused by: org.apache.solr.common.SolrException: Error loading solr config from solr/collection1/solrconfig.xml
        at org.apache.solr.core.SolrConfig.readFromResourceLoader(SolrConfig.java:148)
        at org.apache.solr.core.ConfigSetService.createSolrConfig(ConfigSetService.java:79)
        at org.apache.solr.core.ConfigSetService.getConfig(ConfigSetService.java:61)
        ... 9 more
Caused by: java.io.IOException: Can't find resource 'solrconfig.xml' in classpath or '/usr/local/alfresco-5.0.d/solr/collection1/conf'
        at org.apache.solr.core.SolrResourceLoader.openResource(SolrResourceLoader.java:362)
        at org.apache.solr.core.SolrResourceLoader.openConfig(SolrResourceLoader.java:308)
        at org.apache.solr.core.Config.<init>(Config.java:116)
        at org.apache.solr.core.Config.<init>(Config.java:86)
        at org.apache.solr.core.SolrConfig.<init>(SolrConfig.java:161)
        at org.apache.solr.core.SolrConfig.readFromResourceLoader(SolrConfig.java:144)
        ... 11 more

I don't know if this has to do with my login problem, but I have no idea what he means with collection1? Solr4 is stated to be running after all. Neither I have no idea where the solrconfig.xml file should be located.

I did search for some days searching Alfresco discussions about similar problems, but nothing really helped on this issue. I would be very greatful for any help.

1 Solution

Accepted Solutions
Master

Re: I can't login into /share but I find nothing in my log files.

Jump to solution

That means SOLR indexing now works and you could search for content - if you were able to log in that is...

What did you set for the authentication chain in alfresco-global.properties? If you have not enabled alfrescoNtlm then you cannot login as admin because Alfresco will not use the internal user data and MD4 hash...

View solution in original post

16 Replies
Master

Re: I can't login into /share but I find nothing in my log files.

Jump to solution

From the SOLR log it does not look like it necessarily started successfully. The collection1 core should not exist - instead there should be cores for alfresco and archive.

Also, you may not get anything in the logs for the login, but could already have something concerning the startup of the application. E.g. if Alfresco Repository failed to startup (see alfresco.log), Share will never be able to process a login regquest.

Active Member II

Re: I can't login into /share but I find nothing in my log files.

Jump to solution

Do you have an idea where collection1 could have been defined?

Alfresco not does not contain any error (neither catalina.out, neither alfresco.log), not even during reloading the app. So I suppose alfresco should run fine?

The only error I see is with solr4, as stated above.

Master

Re: I can't login into /share but I find nothing in my log files.

Jump to solution

collection1 is defined via the path '/usr/local/alfresco-5.0.d/solr/collection1' - that should not exist. Instead, there should be a /usr/local/alfresco-5.0.d/solr/alfresco and /usr/local/alfresco-5.0.d/solr/archive in a typical Alfresco installation.

That reminds me to ask: How did you install Alfresco?

Also, did you check the Tomcat access logs for any requests that Share did against the Repository that may have failed?

It often is the easiest option to attach all log files to a question so you can avoid the back-and-forth.

Active Member II

Re: I can't login into /share but I find nothing in my log files.

Jump to solution

Hmm, I don't have any archive or Alfresco directories beneith solr4, but I have an archive-SpacesStore and workspace-SpacesStore ...

[root@vm-a530-212 plan]# ls -l /usr/local/alfresco/solr4/
total 40
drwxr-xr-x 2 root root 4096 Jun 29  2015 alfrescoModels
drwxr-xr-x 3 root root 4096 Jun 29  2015 archive-SpacesStore
drwxr-xr-x 2 root root 4096 Jul 21 11:15 conf
drwxr-xr-x 2 root root 4096 Oct 19  2016 ContentStore
drwxr-xr-x 2 root root 4096 Jun 29  2015 lib
-rw-r--r-- 1 root root  866 Mar 19  2015 log4j-solr.properties
-rw-r--r-- 1 root root  436 Jul 18 15:41 solr4.xml
-rw-r--r-- 1 root root  147 Mar 19  2015 solr.xml
drwxr-xr-x 3 root root 4096 Jun 29  2015 templates
drwxr-xr-x 3 root root 4096 Jun 29  2015 workspace-SpacesStore

What I have:

/usr/local/alfresco-5.0.d/alf_data/solr4/index/archive

/usr/local/alfresco-5.0.d/alf_data/solr4/index/workspace

The only thing I get to see in acces-log (/var/log/alfresco/localhost_access_log.2017-07-24.txt) during a login-attempt:

127.0.0.1 - - [24/Jul/2017:11:20:16 +0200] "POST /alfresco/s/api/login HTTP/1.1" 403 369
192.168.211.1 - - [24/Jul/2017:11:20:16 +0200] "POST /share/page/dologin HTTP/1.1" 302 -
192.168.211.1 - - [24/Jul/2017:11:20:16 +0200] "GET /share/page/?error=true HTTP/1.1" 200 37889

In fact our mother company gave us an image of their "Intranet"-server by after deleting their alfresco-content. We did install that image, but there where some problems. So I moved the solr4, and SpacesStore directories to "trash", I defined a new empty database and a new empty dir.root  (/opt/alfresco-5.0.d/alf_data2). I then restarted Alfresco. The database and data-store seemed to recreate as expected.

Master

Re: I can't login into /share but I find nothing in my log files.

Jump to solution

Ok, archive-SpacesStore and workspace-SpaceStore are also fine. These are slightly more elaborate names (used in previous versions) but the same as just archive or alfresco.

Ok. so it looks like the Alfresco Repository has started prroperly (or it would return a 404 instead of a 403 for the /alfresco/s/api/login call). It really does look like it is simply a matter of incorrect credentials after all.

You said you tried "default username and password, as saved in mysql database". I hope you did not try the username / password of the database user - that is only for Alfresco to connect to the database and not for user authentication. There is only one default username / password when you install Alfresco in a new database - user admin with the password admin.

Active Member II

Re: I can't login into /share but I find nothing in my log files.

Jump to solution

What I still find confusing is the errro about "collection1".

Here what I no about the credentials:

I am trying with admin / admin. What I found in database is the md4-hash stated as default one corresponding to 'admin':

mysql> SELECT anp1.node_id,     anp1.qname_id,   anp1.string_value       

FROM alf_node_properties anp1     

INNER JOIN alf_qname aq1 ON aq1.id = anp1.qname_id      

INNER JOIN alf_node_properties anp2 ON anp2.node_id = anp1.node_id       

INNER JOIN alf_qname aq2 ON aq2.id = anp2.qname_id                    

WHERE aq1.local_name = 'password' AND aq2.local_name = 'username'

  AND anp2.string_value = 'admin';
+---------+----------+----------------------------------+
| node_id | qname_id | string_value                     |
+---------+----------+----------------------------------+
|       4 |       11 | 209c6174da490caeb422f3fa5a7ae634 |
+---------+----------+----------------------------------+

Master

Re: I can't login into /share but I find nothing in my log files.

Jump to solution

The error with collection1 may have something to do with the context XML for solr4 not listing the correct path for solrHome which will have SOLR default to the out-of-the-box configuration which includes collection1. Check your tomcat/conf/Catalina/localhost/solr4.xml and correct the path(s) where necessary.

Active Member II

Re: I can't login into /share but I find nothing in my log files.

Jump to solution

I have solr4.xml:

<?xml version="1.0" encoding="utf-8"?>
<Context crossContext="true">
  <Environment name="solr/home"        type="java.lang.String" value="@@ALFRESCO_SOLR4_DIR@@" override="true"/>
  <Environment name="solr/model/dir"   type="java.lang.String" value="@@ALFRESCO_SOLR4_MODEL_DIR@@" override="true"/>
  <Environment name="solr/content/dir" type="java.lang.String" value="@@ALFRESCO_SOLR4_CONTENT_DIR@@" override="true"/>
</Context>

and solr.xml:

<?xml version='1.0' encoding='UTF-8'?>
<solr>
   <str name="adminHandler">${adminHandlerSmiley Surprisedrg.alfresco.solr.AlfrescoCoreAdminHandler}</str>
</solr>

In alfresco-global.properties I have the following concerning solr:

### Solr indexing ###
index.subsystem.name=solr4
dir.keystore=${dir.root}/keystore
solr.port.ssl=8443

Master

Re: I can't login into /share but I find nothing in my log files.

Jump to solution

All the paths with @@ as demarcation should have proper path values set that correspond with the config location (solr/home) and the locations where you want to store runtime data (solr/model/dir and solr/content/dir). It is extremely advisable not to point solr/content/dir to a location inside of solr/home, or the startup of SOLR will get extremely delayed in the long run...