"api name must be lowercase" during logon after upgrade to Community 6.2 / ACA 1.9

cancel
Showing results for 
Search instead for 
Did you mean: 
Active Member

"api name must be lowercase" during logon after upgrade to Community 6.2 / ACA 1.9

Jump to solution

Hello,

I've just udated to ACS 6.2 Community Edition & v1.9 of the ADF example app, and have been getting this error message on the  server console every time I attempt to authenticate.

I'm using basic auth managed by ACS, and I can see that there are no upper case characters present in the login request URL (from the Tomcat access log).

Login URLs are appearing in the form :

//alfresco/api/default-/public/authentication/versions/1/tickets

I'm wondering if anyone can see or recommend anything obvious?

Thank you

 

 

 

 

 

"exception from executeScript" "api name must be lowercase"

1 Solution

Accepted Solutions
Active Member

Re: "api name must be lowercase" during logon after upgrade to Community 6.2 / ACA 1.9

Jump to solution

Please ignore this request - I've discovered that a trailing slash character in the ADF app.config.json "ecmHost" setting was causing the problem.

View solution in original post

2 Replies
Active Member

Re: "api name must be lowercase" during logon after upgrade to Community 6.2 / ACA 1.9

Jump to solution

Please ignore this request - I've discovered that a trailing slash character in the ADF app.config.json "ecmHost" setting was causing the problem.

View solution in original post

Active Member

Re: "api name must be lowercase" during logon after upgrade to Community 6.2 / ACA 1.9

Jump to solution

I have the same problem. How did you solve it?