"Something's wrong with this page ..."

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member II

"Something's wrong with this page ..."

Getting an error when i open the Alfresco

Hey guys, Can anyone tell why I'm getting this problem(in attached image). Some people suggested and they've solved this problem by adding the below code, I couldn't get to which file i should place the below code.

ProxyPreserveHost On

ProxyRequests Off

Help me out guys.. i stuck here from past 2 weeks.

(Please mention the filename and the path)

Thnx in advance..

4 Replies
Highlighted
Advanced II

Re: Hi,

Hello.

That image alone is not enough to identify what is wrong.

Check the log files (alfresco.log, catalina.out, share.log) and give us more details.

Highlighted
Active Member II

Re: Hi,

All the 3 log files are attached in below link.. FYI.

Let me know if you require some more files..

Dropbox - Alfresco Logs 

Highlighted
Master

Re: "Something's wrong with this page ..."

You have a clear error message in the log:

Caused by: org.springframework.extensions.surf.exception.PlatformRuntimeException: 09240000 No 'login' page type configured - but page auth required it.

It would be good to know what general changes you have made to the Alfresco Share application. Out-of-the-box you will never have this kind of an error, so you must have changed some configuration, deleted some files / build the share.war in some funny way, or installed an addon that messes with some things.

Highlighted
Member II

Re: "Something's wrong with this page ..."

Hello

I got the same error. On a Windows 10 platform. http://127.0.0.1:8080/share/page/ page gives the error. In the share file there is the following log. I did not change any thing. 

2017-12-02 17:02:22,339 ERROR [org.springframework.extensions.surf.render.RenderService] [http-apr-8080-exec-2] An exception occurred while rendering: slingshot-login
org.springframework.extensions.surf.exception.RendererExecutionException: Cannot resolve template - may be missing from the definition: template-instance: simple-guest, <?xml version="1.0" encoding="UTF-8"?>

Alfresco info : 

Alfresco Community (Build: 6.0.0-ea)
===============================
Contains:
 - Alfresco Content Services Community: 6.0.0-ea
 - Alfresco Share:  5.2.f

Thanks