Root object person.getPerson seems to not work properly

Showing results for 
Search instead for 
Did you mean: 
Member II

Root object person.getPerson seems to not work properly

Hello everybody!

I'm writing to get some help or some idea about why something is happening in my Alfresco Content Service environment. I have built some extensions over my instance using Javascript based Webscripts. All of them work perfectly, however I do have one exception. The problem is: in one webscript I invoke the Javascript root object person.getPerson ( in this way:

var userNodes = people.getPeople(null,0);

And it doesn't return anything, however, I do have some users registered in my instance. Also, I can see all of them using the node browser and the following Alfresco-CMIS query:

SELECT * FROM cm:person

I tried to test the same webscript in a test instance and it worked without problems. So, I don't think the code is the problem. In addition, I have read the implementation of the root object ( And I discover that, "under the hoods", the code creates the following FTS query and passes it to the SearchService:

TYPE:"{}person" AND ("***")

I tried to verify this query in the node browser too and it didn't return anything too. I also tried to remove the "AND ("***")" snippet from the query and then it worked without any problems.

Do someone know what could be and why the query without "AND ("***")" works properly?


Some informations about my environment:

Alfresco's version: 6.2

Edition: Community


Thanks in advance!