SDK3.0.1 Platform-jar : new JAR are not created

cancel
Showing results for 
Search instead for 
Did you mean: 
Established Member II

SDK3.0.1 Platform-jar : new JAR are not created

Jump to solution

Hi,

I have reported source code from sdk 2.2 alfresco project to a new alfresco project with sdk 3.0.1. by using the sdk 3.0.1 template.

Some dependencies are declared in platform-jar module POM.xml.

<!-- appache FTP -->
<dependency>
   <groupId>commons-net</groupId>
   <artifactId>commons-net</artifactId>
   <version>3.3</version>
</dependency>

<!-- Samba dependencies -->
<dependency>
   <groupId>jcifs</groupId>  
   <artifactId>jcifs</artifactId>
   <version>1.3.17</version>
</dependency>
<dependency>
   <groupId>ca.uhn.hapi</groupId>
   <artifactId>hapi-base</artifactId>
   <version>2.2</version>
</dependency>

<!-- Also add hapi-structures-v22, v23, etc. depending on which versions
of HL7 you need to create or parse -->
  <dependency>
   <groupId>ca.uhn.hapi</groupId>
   <artifactId>hapi-structures-v251</artifactId>
   <version>2.2</version>
</dependency>

<dependency>
   <groupId>org.apache.tika</groupId>
   <artifactId>tika-core</artifactId>
   <version>1.12</version>
</dependency>

But the jar (hapi-base, hapi-structures-v251, tika-core, etc...) are not created during the build.

And so when i launch the project i have an issue on TOMCAT :

On the former project (sdk 2.2) , the jar were well generated...

How can i solve it ?

Thx

1 Solution

Accepted Solutions
Established Member II

Re: SDK3.0.1 Platform-jar : new JAR are not created

Jump to solution

All is ok, I solve it by adding dependencies in platform pom file AND in main pom file :

java - Alfresco Context initialization failed : NoClassDefFoundError - Stack Overflow 

Thank you

View solution in original post

2 Replies
Advanced II

Re: SDK3.0.1 Platform-jar : new JAR are not created

Jump to solution

Can you elaborate?

I could not understand the problem you are facing.

Established Member II

Re: SDK3.0.1 Platform-jar : new JAR are not created

Jump to solution

All is ok, I solve it by adding dependencies in platform pom file AND in main pom file :

java - Alfresco Context initialization failed : NoClassDefFoundError - Stack Overflow 

Thank you

View solution in original post