Send email with attachments

Showing results for 
Search instead for 
Did you mean: 
Active Member

Send email with attachments

I was able to setup and send email from backend using Alfresco's MailExecutorAction. It works fine, but it doesn't allow to send attachments. We tried.

Found this but when i configure it, my system fails to start: 

Has anyone tried this. I get null pointer error

Failed to execute asynchronous action: Action[ id=8ysce79d-234a-4e62-b76b-100454c36g6h, node=null ] java.lang.NullPointerException

Can you guide me to correct documentation regarding MailExecutorAction on how to send attachments also? 


1 Reply

Re: Send email with attachments

There is no specific documentation for "MailExecutorAction " as far as i know. yes Outofthebox implementation doesn't support sending the attachment. 

I have not tried the MailWithAttachements extension  so not sure what could have caused the issue, but likely you have some sort of miss configuration in the bean definition. Not so sure though as you have not shared the full stack trace.

A similar issue can also be found here: 

Take a look and see if that helps 

(ACSCE, AWS SAA, Azure Admin)