SEVERE [main] org.apache.catalina.startup.HostConfig.deployDescriptor Error deploying deployment descriptor

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
resnicke
Member II

SEVERE [main] org.apache.catalina.startup.HostConfig.deployDescriptor Error deploying deployment descriptor

Ubuntu 16.04
Tomcat 9.0.14Alfresco 6.0.7

MySQL 5.7.24-0

- New installation (first time for me)

  • URL:8080 gives the following error:
    Cannot find Alfresco Repository on this server. (Does this application have access to alfresco-global.properties? Does this application have cross-context permissions?)
  • SEVERE error in catalina.out:
SEVERE [main] org.apache.catalina.startup.HostConfig.deployDescriptor Error deploying deployment descriptor [/opt/tomcat/conf/Catalina/localhost/alfresco.xml]

catalina.log file attached.

7 Replies
resnicke
Member II

Re: SEVERE [main] org.apache.catalina.startup.HostConfig.deployDescriptor Error deploying deployment descriptor

What other files should I send to help figure out the issue?

resnicke
Member II

Re: SEVERE [main] org.apache.catalina.startup.HostConfig.deployDescriptor Error deploying deployment descriptor

I think the problem is in the XML files in /opt/tomcat/conf/Catalina/localhost/ (see below).

I don't have the directories ${catalina.base}/../modules/platform or ${catalina.base}/../modules/share

What part of the configuration did I miss and how do I fix it?

-----

# cd /opt/tomcat/conf/Catalina/localhost/
# cat *
<?xml version='1.0' encoding='utf-8'?>
<Context crossContext="true">
  <Resources>
    <PostResources base="${catalina.base}/../modules/platform"
                   className="org.apache.catalina.webresources.DirResourceSet"
                   webAppMount="/WEB-INF/lib"/>
  </Resources>
</Context>
<?xml version='1.0' encoding='utf-8'?>
<Context crossContext="true">
  <Resources>
    <PostResources base="${catalina.base}/../modules/share"
                   className="org.apache.catalina.webresources.DirResourceSet"
                   webAppMount="/WEB-INF/lib"/>
  </Resources>
</Context>

jpotts
Advanced II

Re: SEVERE [main] org.apache.catalina.startup.HostConfig.deployDescriptor Error deploying deployment descriptor

Eddy,

Before 6.0 there was a binary installer that worked great for folks that were new to the platform or people who just wanted the installer to do a bit of work for them (there are definitely those that absolutely hated the installer).

Now, in 6.0, you can either use Docker, which not everyone likes to use, or you can install manually, which is what it sounds like you are trying to do.

Have you seen this: GitHub - loftuxab/alfresco-ubuntu-install: Alfresco script based install for Ubuntu 

You might want to give it a try. It installs Alfresco the way Loftux likes to install Alfresco. If that meets your needs, then great! If it doesn't, you can use the install as a working example and make tweaks to customize as needed.

Jeff

resnicke
Member II

Re: SEVERE [main] org.apache.catalina.startup.HostConfig.deployDescriptor Error deploying deployment descriptor

I am having issues in pulling from github (curl or wget) and therefore can not use your suggestion.

# curl -v -O --ssl-no-revoke https://raw.githubusercontent.com/loftuxab/alfresco-ubuntu-install/master/alfinstall.sh
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0*   Trying 151.101.0.133...
* Connected to raw.githubusercontent.com (151.101.0.133) port 443 (#0)
* found 148 certificates in /etc/ssl/certs/ca-certificates.crt
* found 594 certificates in /etc/ssl/certs
* ALPN, offering http/1.1
* gnutls_handshake() failed: Error in the pull function.
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
* Closing connection 0
curl: (35) gnutls_handshake() failed: Error in the pull function.

So I am trying to make do with what I installed on my own - with the same issues. Can I send you a log file for your perusal?

jpotts
Advanced II

Re: SEVERE [main] org.apache.catalina.startup.HostConfig.deployDescriptor Error deploying deployment descriptor

Did you ever get this working? Your XML looks okay to me.

If you are still struggling with it let me know where you are stuck.

Jeff

resnicke
Member II

Re: SEVERE [main] org.apache.catalina.startup.HostConfig.deployDescriptor Error deploying deployment descriptor

I started from scratch and used the installer from Bitnami – worked first time.

I'm looking for a good tool to create a SVG logo to replace the logo Alfresco logo – do you know of any good tools?

Eddy

jpotts
Advanced II

Re: SEVERE [main] org.apache.catalina.startup.HostConfig.deployDescriptor Error deploying deployment descriptor

Inkscape or Gimp for open source tools. Sketch or Photoshop for commercial tools.