Share Login problem while installing alfresco 6.1

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
kamendrasingh
Active Member II

Share Login problem while installing alfresco 6.1

Jump to solution

I was using alfresco 5.2 before now im upgrading to 6.1. And im facing some issues while installing version 6.1.

After installation im able to login into alfresco-share as admin but after deploying the amps or jars of the my project im not able to login. It showing me the error "Your authentication details haven't been recognized or Alfresco Content Services may not be available at this time." while im logging into alfresco-share. Im using postgres as DB in different server. I modified docker-compose.yml for DB. Please help me out.

1 Solution

Accepted Solutions
Moderator
Moderator

Re: Share Login problem while installing alfresco 6.1

Jump to solution

Were you able to run default project generated using SDK 4.0 successfully and were you able to login? JodConverter library error is informational, notice the message says "The following error is shown for informational purposes only." You can ignore this error.

Did you saw image magic and pdf renderer related errors with default project ? Please attach the full log.

12 Replies
Moderator
Moderator

Re: Share Login problem while installing alfresco 6.1

Jump to solution

As i understand, you are able to login with OOTB installation so i don't think it has something to do with DB. Could you cross check log files to see if you can find any errors? Also, please check if you have enabled any CSRFPolicy in your custom share amp, it may be causing the issue. I had similar issues after upgrading from version 5.2.5 to 6.1 and when i commented out CSRFPolicy from share config, then it worked. However this may not be the same issue in your case.

kamendrasingh
Active Member II

Re: Share Login problem while installing alfresco 6.1

Jump to solution

No im still having the problem.

What should i deploy in 6.1 jars or apms?

In logs it is showing "Unable to retrieve License information from Alfresco: 404" Error?

If anyone knows please help me out ?

Moderator
Moderator

Re: Share Login problem while installing alfresco 6.1

Jump to solution

There is no restrictions related to jar file or amps. You can use any of these. Did you verified CSRFPolicy config? I used to see same error in my case too. When i updated the config to:

<config evaluator="string-compare" condition="CSRFPolicy" replace="true">
    <filter/>
</config>

then it started working. 

kamendrasingh
Active Member II

Re: Share Login problem while installing alfresco 6.1

Jump to solution

Still it is not working for me.

Should we include alfresco-global.properties in new version?

And im getting "Unable to start JodConverter library. The following error is shown for informational purposes only" error.

Moderator
Moderator

Re: Share Login problem while installing alfresco 6.1

Jump to solution

Can you attach the full log from startup to login failure? Please include all logs (alfresco.log, share.log and catalina.out) if creating separately.

kamendrasingh
Active Member II

Re: Share Login problem while installing alfresco 6.1

Jump to solution

I am trying to install it from 1 week still iam getting the same error.

Can you please tell me the full process for upgrading to 5.2 to 6.1 version or provide any reference?

Iam using alfresco 5.2 community edition.

Moderator
Moderator

Re: Share Login problem while installing alfresco 6.1

Jump to solution

Tell the steps you are following. How is your current installation ? docker? or standard installation ? 

kamendrasingh
Active Member II

Re: Share Login problem while installing alfresco 6.1

Jump to solution

Before I was working on alfresco 5.2. It was simple to install the project using alfresco sdk 3.0. Now iam upgrading to sdk 4.0 as alfresco community edition 6.1 needed it. So first iam upgrading my project to sdk 4.0 using this link https://github.com/Alfresco/alfresco-sdk/blob/sdk-4.0/docs/advanced-topics/upgrading.md . But when im running it im unable to login to share and it showing the error  "unable to reterive the license 404 not found". The docker image it generating is image: alfresco-share-indsolv-alfresco:development.

Moderator
Moderator

Re: Share Login problem while installing alfresco 6.1

Jump to solution

I would rather follow these steps, to make things simple and clean.

1- Generate default SDK 4.0 archetype using : mvn archetype:generate -Dfilter=org.alfresco:

2- Select the jar type or amp type depending on your existing setup. For example if i have All-in-one Jar archetype (AIO Jar archetype) using SDK 3.0 which i was using for 5.2 and now i am upgrading to 6.1 so i would need AIO archetype using SDK4.0. I would select the option 2 here:

2: remote -> org.alfresco.maven.archetype:alfresco-allinone-archetype (Sample multi-module project for All-in-One development on the Alfresco platform. Includes modules for Platform/Repository JAR and Share JAR)

3- Follow the prompts as asked and generate the AIO Archetype. Provide the artifact id, group id, package etc. as per your current project on prompt.

4- Once project structure is ready using SDK 4.0, try an initial run to make sure its working, you are able to login to repo etc. You can follow the ReadMe file generated with SDK 4 to build/start/stop containers. A run.bat/run.sh file can be found with generated project which can be used to build and start docker containers. Please make sure you have installed docker on your machine.

5- Once your initial test is completed, purge the docker volumes (Follow the ReadMe file).

6- Copy all the customizations (which you have in sdk 3) for Repo and Share layers to appropriate projects in new structure and remove all unnecessary files/folders generated using sdk 4.0 project structure if required. 

7- Add all custom dependencies which you may have used in your existing project.

8- After you are done with copy and restructuring with your custom code, you can build and start the docker container again with your custom code. 

I have attached a sample project generated using SDK4.0 for reference.