Simple custom Indicators not work

cancel
Showing results for 
Search instead for 
Did you mean: 
Established Member II

Simple custom Indicators not work

Hi,

Continuing my study to create a simple custom indicators (on my preivous post: How to change default icon folder based on its properties? ), I start to create it with reference from Jeff's post here Colour vs tags .

I create ar:dirFungsi properties applied to a folder which will add a custom indicator.

Following are my steps and codes:

1. Add an evaluator /tomcat/webapps/share/WEB-INF/classes/alfresco/custom-slingshot-application-context.xml

<?xml version='1.0' encoding='UTF-8'?>

<!DOCTYPE beans PUBLIC '-//SPRING//DTD BEAN//EN' 'http://www.springframework.org/dtd/spring-beans.dtd'>

<beans>

  <!-- Directory Obyektif Evaluator -->

  <bean id="evaluator.doclib.action.dirObyektif" parent="evaluator.doclib.action.value">

     <property name="accessor" value="node.properties.ar:dirFungsi" />

     <property name="comparator">

        <bean class="org.alfresco.web.evaluator.StringEqualsComparator">

           <property name="value" value="DirObyektif" />

        </bean>

     </property>

  </bean>

</beans>

2. Add indicator inside condition attribute equals to DocumentLibrary in /tomcat/shared/classes/alfresco/web-extension/share-config-custom.xml

     <indicators>

        <indicator id="dirobyektif" index="100">

           <evaluator>evaluator.doclib.action.dirObyektif</evaluator>

        </indicator>

     </indicators>

3. Create an image in /tomcat/webapps/share/components/documentlibrary/indicators/dirobyektif-16.png

Then I restarted the server, but the indicator doesn't appear.

What is the problem and how to solve it?

Thanks,

[bayu]

3 Replies
Established Member II

Re: Simple custom Indicators not work

don't add your customizations to /share nor /alfresco 
check the documentation here:

Evaluators | Alfresco Documentation 

re-do your first step, adding evaluator to this file: 

tomcat/shared/classes/alfresco/web-extension/custom-slingshot-application-context.xml 

Established Member II

Re: Simple custom Indicators not work

Hi Markus Joos

I have put the evaluator as suggested, but the indicator still not appear Smiley Sad

I also checked share.log & alfresco.log but nothing errors found.

Is there any misconfigure syntax on my files above?

My idea is simple, evaluator will check the folder property ar:dirFungsi value is "DirObyektif", if true, the custom indicator will appear.

Thanks,

Established Member II

Re: Simple custom Indicators not work

Anyone can help my problem, pls?

Thank you in advance.