Solr 4 to Solr6 update problem

cancel
Showing results for 
Search instead for 
Did you mean: 
statira
Active Member

Solr 4 to Solr6 update problem

Jump to solution

I have alfresco communitu 5.2 which I'm planning to update to 6.2.(can I go straight to 6.2 by the way?) The documentation says to upgrade Search Services to Solr6 first, so I installed alfresco-search-services-2.1.0-A5.zip as discribed here https://docs.alfresco.com/search-enterprise/tasks/solr-install-withoutSSL.html. It's up and running on the same server, in my alfresco-global.properties I've changed this

index.subsystem.name=solr4
dir.keystore=${dir.root}/keystore
solr.host=localhost
solr.port.ssl=443

to this

index.subsystem.name=solr
solr.secureComms=none
solr.port=8983

solr.host=liza-alf.diasoft.ru
solr.baseUrl=/solr

Solr6 is located in /opt/alfresco-community/alfresco-search-services

openjdk version "13.0.4"

The is no connection between Alfresco and Solr

java.net.ConnectException: Connection refused
	at java.base/sun.nio.ch.Net.connect0(Native Method)
	at java.base/sun.nio.ch.Net.connect(Net.java:493)
	at java.base/sun.nio.ch.Net.connect(Net.java:482)
	at java.base/sun.nio.ch.NioSocketImpl.connect(NioSocketImpl.java:588)
	at java.base/java.net.SocksSocketImpl.connect(SocksSocketImpl.java:339)
	at java.base/java.net.Socket.connect(Socket.java:603)
	at java.base/java.net.Socket.connect(Socket.java:552)
	at java.base/java.net.Socket.<init>(Socket.java:475)
	at java.base/java.net.Socket.<init>(Socket.java:325)
	at org.apache.commons.httpclient.protocol.DefaultProtocolSocketFactory.createSocket(DefaultProtocolSocketFactory.java:80)
	at org.apache.commons.httpclient.protocol.DefaultProtocolSocketFactory.createSocket(DefaultProtocolSocketFactory.java:122)
	at org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:707)
	at org.apache.commons.httpclient.MultiThreadedHttpConnectionManager$HttpConnectionAdapter.open(MultiThreadedHttpConnectionManager.java:1361)
	at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:387)
	at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171)
...

 

 

2 Solutions

Accepted Solutions
abhinavmishra14
Advanced

Re: Solr 4 to Solr6 update problem

Jump to solution

If you are using ACS5.2.x and trying to upgrade solr6 version 2.1.0-A5 then it may not work. As per documentation, 5.2.x supports only search services 1.3.

https://docs.alfresco.com/5.2/concepts/supported-platforms-ACS.html

So, try upgrading to v1.3 first to use 5.2.x with solr6

Have a look at this post as well: https://hub.alfresco.com/t5/alfresco-content-services-blog/search-services-upgrade-paths/ba-p/304202

In alfresco-global.properties, note the subsystem. It should be solr6 not solr:

solr.host=liza-alf.diasoft.ru
solr.port=8983
solr.secureComms=none #Possible values are: none, https
solr.base.url=/solr
index.subsystem.name=solr6

Update the 'solr.in.sh' with following env variables:

SOLR_SOLR_HOST=liza-alf.diasoft.ru
SOLR_SOLR_PORT=8983
SOLR_SOLR_BASEURL=/solr
SOLR_ALFRESCO_HOST=<update the alfresco host here>
SOLR_ALFRESCO_PORT=8080
SOLR_ALFRESCO_BASEURL=/alfresco
SOLR_ALFRESCO_SECURECOMMS=none

Optionally, you can update the above configs in 'alfresco-search-services/solrhome/templates/rerank/conf/solrcore.properties': 

alfresco.secureComms=none
alfresco.host=<update the alfresco host here> alfresco.port=8080 alfresco.baseUrl=/alfresco

 

~Abhinav
(ACSCE, AWS SAA-C02, GAIQ)

View solution in original post

EddieMay
Community Manager
Community Manager

Re: Solr 4 to Solr6 update problem

Jump to solution

Hi @statira 

There have been a couple of threads about related topics - this one might be useful, also this one. This 2019 DevCon slide deck might be useful too - all the recorded sessions are available here.

HTH,

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!

View solution in original post

6 Replies
abhinavmishra14
Advanced

Re: Solr 4 to Solr6 update problem

Jump to solution

If you are using ACS5.2.x and trying to upgrade solr6 version 2.1.0-A5 then it may not work. As per documentation, 5.2.x supports only search services 1.3.

https://docs.alfresco.com/5.2/concepts/supported-platforms-ACS.html

So, try upgrading to v1.3 first to use 5.2.x with solr6

Have a look at this post as well: https://hub.alfresco.com/t5/alfresco-content-services-blog/search-services-upgrade-paths/ba-p/304202

In alfresco-global.properties, note the subsystem. It should be solr6 not solr:

solr.host=liza-alf.diasoft.ru
solr.port=8983
solr.secureComms=none #Possible values are: none, https
solr.base.url=/solr
index.subsystem.name=solr6

Update the 'solr.in.sh' with following env variables:

SOLR_SOLR_HOST=liza-alf.diasoft.ru
SOLR_SOLR_PORT=8983
SOLR_SOLR_BASEURL=/solr
SOLR_ALFRESCO_HOST=<update the alfresco host here>
SOLR_ALFRESCO_PORT=8080
SOLR_ALFRESCO_BASEURL=/alfresco
SOLR_ALFRESCO_SECURECOMMS=none

Optionally, you can update the above configs in 'alfresco-search-services/solrhome/templates/rerank/conf/solrcore.properties': 

alfresco.secureComms=none
alfresco.host=<update the alfresco host here> alfresco.port=8080 alfresco.baseUrl=/alfresco

 

~Abhinav
(ACSCE, AWS SAA-C02, GAIQ)

View solution in original post

EddieMay
Community Manager
Community Manager

Re: Solr 4 to Solr6 update problem

Jump to solution

Hi @statira 

There have been a couple of threads about related topics - this one might be useful, also this one. This 2019 DevCon slide deck might be useful too - all the recorded sessions are available here.

HTH,

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!

View solution in original post

statira
Active Member

Re: Solr 4 to Solr6 update problem

Jump to solution

Search services 1.3 works fine, thanks!

EddieMay
Community Manager
Community Manager

Re: Solr 4 to Solr6 update problem

Jump to solution

@statira 

Glad you got it working & thanks for updating your thread - really useful to other users.

Cheers,

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!
abhinavmishra14
Advanced

Re: Solr 4 to Solr6 update problem

Jump to solution

@statira wrote:

Search services 1.3 works fine, thanks!


Glad to hear @statira , good luck.

~Abhinav
(ACSCE, AWS SAA-C02, GAIQ)
abhinavmishra14
Advanced

Re: Solr 4 to Solr6 update problem

Jump to solution

@statira moved your heap space issue to new thread for clarity. 

~Abhinav
(ACSCE, AWS SAA-C02, GAIQ)