Solr of ASSCE 1.4 from ACE 201911GA install have connection errors and timeout warns

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

Solr of ASSCE 1.4 from ACE 201911GA install have connection errors and timeout warns

I have tried to install Alfresco Search Services Community Edition from the Alfresco Community Edition 201911GA bundle, but I get an error in the Solr log after finishing this page: https://docs.alfresco.com/search-community/tasks/solr-install-withoutSSL.html

I have modified the rerank/conf/solrcore.properties file to set SecureComms to none there, too. I have commented out the SSL part in the Tomcat server.xml file:

<!--
    Solr

    <Connector port="8443" protocol="org.apache.coyote.http11.Http11Protocol"
               SSLEnabled="true" maxThreads="150" scheme="https"
               keystoreFile="xxxxx"
               keystorePass="password" keystoreType="JCEKS"
               secure="true" connectionTimeout="240000"
               truststoreFile="xxxxx"
               truststorePass="password" truststoreType="JCEKS"
               clientAuth="want" sslProtocol="TLS" />
    -->

alfresco-global.properties:

index.subsystem.name=solr6
solr.secureComms=none
solr.port=8983

rerank/conf/solrcore.properties:

# encryption

# none, https
alfresco.secureComms=none

but still get error when create alfresco and archive cores:

2020-06-24 11:58:02.023 ERROR (searcherExecutor-7-thread-1-processing-x:alfresco) [   x:alfresco] o.a.s.t.AbstractTracker Model trackin
g failed for core: alfresco
java.net.ConnectException: Kapcsolat elutasítva (Connection refused)
        at java.base/java.net.PlainSocketImpl.socketConnect(Native Method)

and the rest of the log is full with timeouts:

2020-06-24 11:58:10.039 WARN  (org.alfresco.solr.AlfrescoCoreAdminHandler@a23a01d_Worker-3) [   ] o.a.s.t.AbstractTracker Tracking comm
unication timed out for AclTracker - archive
2020-06-24 11:58:10.043 WARN  (org.alfresco.solr.AlfrescoCoreAdminHandler@a23a01d_Worker-1) [   ] o.a.s.t.AbstractTracker Tracking comm
unication timed out for ModelTracker - alfresco

What is wrong with my Solr install?

 

5 Replies
Highlighted
Alfresco Employee

Re: Solr of ASSCE 1.4 from ACE 201911GA install have connection errors and timeout warns

Is Repository running in http://localhost:8080/alfresco?

Software Engineer in Alfresco Search Team.
Highlighted
Active Member

Re: Solr of ASSCE 1.4 from ACE 201911GA install have connection errors and timeout warns

Not yet. Following the steps from https://docs.alfresco.com/community/tasks/alf-war-install.html Tomcat is not started yet.

During an earlier attempt I have started it, catalina log:

 

24-Jun-2020 13:12:35.784 SEVERE [localhost-startStop-1] org.apache.catalina.core.ContainerBase.addChildInternal ContainerBase.addChild:
 start:
        org.apache.catalina.LifecycleException: Failed to initialize component [org.apache.catalina.webresources.DirResourceSet@7c09645
7]

because of

 

 

Caused by: java.lang.IllegalArgumentException: The directory specified by base and internal path [/opt/alfresco-201911/tomcat/.
./modules/platform]/[] does not exist.

so I have decided not to start it until mentioned in the setup step.

 

 

I see this with an Alfresco favicon:

 

HTTP Status 404 – Not Found

Type Status Report

Message The requested resource [/alfresco] is not available

Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.
Apache Tomcat/8.5.56

 

Highlighted
Member II

Re: Solr of ASSCE 1.4 from ACE 201911GA install have connection errors and timeout warns

@Peter_Adam_SBdid you ever get this resolved? I have the same issue, except that I am trying to start Alfresco via the Tomcat startup.sh script.

Specifically, here is the first stacktrace that shoes up in the log:

07-Aug-2020 11:30:26.335 SEVERE [localhost-startStop-1] org.apache.catalina.core.ContainerBase.addChildInternal ContainerBase.addChild: start:
	org.apache.catalina.LifecycleException: Failed to initialize component [org.apache.catalina.webresources.DirResourceSet@6ad24b30]
		at org.apache.catalina.util.LifecycleBase.handleSubClassException(LifecycleBase.java:440)
		at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:139)
		at org.apache.catalina.webresources.StandardRoot.initInternal(StandardRoot.java:690)
		at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:136)
		at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:173)
		at org.apache.catalina.core.StandardContext.resourcesStart(StandardContext.java:4803)
		at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:4939)
		at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183)
		at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:743)
		at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:719)
		at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:705)
		at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:614)
		at org.apache.catalina.startup.HostConfig$DeployDescriptor.run(HostConfig.java:1822)
		at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
		at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
		at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
		at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
		at java.base/java.lang.Thread.run(Thread.java:834)
	Caused by: java.lang.IllegalArgumentException: The directory specified by base and internal path [/opt/tomcat8/tomcat8-5-57/../modules/platform]/[] does not exist.
		at org.apache.catalina.webresources.DirResourceSet.checkType(DirResourceSet.java:257)
		at org.apache.catalina.webresources.AbstractFileResourceSet.initInternal(AbstractFileResourceSet.java:206)
		at org.apache.catalina.webresources.DirResourceSet.initInternal(DirResourceSet.java:265)
		at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:136)
		... 16 more
Feel free to connect: https://www.linkedin.com/in/douglasawh/
(leave a note that we talked on the Alfresco board)
Highlighted
Active Member

Re: Solr of ASSCE 1.4 from ACE 201911GA install have connection errors and timeout warns

I have installed Alfresco Search Services 1.2 as I have found only that, and after install and successful run I have upgraded it to 1.4.

 

 

Highlighted
Community Manager
Community Manager

Re: Solr of ASSCE 1.4 from ACE 201911GA install have connection errors and timeout warns

Hi @dwhitfield 

The directory specified by base and internal path [/opt/tomcat8/tomcat8-5-57/../modules/platform]/[] does not exist.

Try creating this folder. See this thread.

HTH,

 

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!