Solr won’t find existing file even after reindex

cancel
Showing results for 
Search instead for 
Did you mean: 
TheUnheard
Member II

Solr won’t find existing file even after reindex

Hello,

In first place sorry for my English it may not be the best.

I am having a problem with solr (or I think so). I have directory and file with the same name as (file is in the folder):

File name:  2021000209.PDF

Folder name: 2021000209

When I run query @CM\:name:"2021000209" through node browser (lucene or fts-alfresco) I only get the folder as a result of the query. When I run the same query for another file it will give me the correct result – it will give me the file and the folder. This problem occurs only for some files.

I tried to delete indexes two times to run automated reindex and it didn’t help. When I try to run query SELECT * FROM utb:contract where cmis:name='2021000209.pdf' through node browser (db-cmis or cmis-strict or cmis-alfresco) it will give me the result I want – the file node.

Please, can someone help me? I don’t know where is the problem (besides it may be solr related) or how to solve it?

I am using  Alfresco Community - 5.2.0.

Thank you for your time and help.

1 Reply
cristinamr
Intermediate II

Re: Solr won’t find existing file even after reindex

Hello,

There is a lot of threads in the forum with same subject. You can find some of them below:

Query Lucene parse error QName with numbers 

Lucene Search: Path Queries 

URGENT!!! Query String 

In short: A numeric character at the beginning of a name is not valid in this context you must to encode it to his ISO9075 representation.

Here is the some documentation: https://community.alfresco.com/docs/DOC-4673-search#jive_content_id_XPath 

I hope this can help.

Cheers!

--
Check our products: AQuA : https://aqua.venzia.es | Seidoc : https://seidoc.es