[Solved] Installation error on Windows 10 x64 (registerservice.bat)

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
maiconramones
Active Member II

[Solved] Installation error on Windows 10 x64 (registerservice.bat)

Hello,

I Installed Alfresco community on my Windows 10 and worked properly.

After some tests, I removed Alfresco community to install again in a fresh environment. But now the same installer doesn't work.

Someone already saw this problem?

2 Replies
maiconramones
Active Member II

Re: Installation error on Windows 10 x64

Any idea?

maiconramones
Active Member II

Re: Installation error on Windows 10 x64

I found the solution...


As you can see the problem appeared on the postgres installation. So as I suspected the problem was with some particularity on postgres environment... To test, I downloaded the postgres installer and the first screen showed the error about the COMSPEC variable. (I hate Windows...)


I started another search about the variable COMSPEC and I found some similar problems herePostgresql 9.4 installation/Windows 8.1/ COMSPEC issue - Stack Overflow  and here Problems Installing PostgreSQL 9.2 - Stack Overflow  . Here there is the technical informations from Microsoft documentation (I hate Windows.. again...)  about the 8.3 filenames https://support.microsoft.com/en-gb/help/121007/how-to-disable-8.3-file-name-creation-on-ntfs-partit... 


I enabled the the 8.3 filename and started the alfresco-comunnity installation again and now works perfectly.


I hope this post its useful to someone including me, because my memory is not so good rsrsrs.


Finally, I hate Windows...