Some Post-Upgrade Issues 4.2.c to 5.2.0

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

Some Post-Upgrade Issues 4.2.c to 5.2.0

I've migrated all of my content and data from my 4.2.c production server over to my 5.2.0 testing server.

The migration went pretty smoothly and I can see the content, logins seem to work correctly, all the users are there, etc.

However, there are some nagging issues that the logs are reporting and I'm not sure how to solve them. So I will post them here in the hopes that somebody else might have some answers.

Issue #1: Active Directory Sync not working? I made sure to copy all the settings for ldap from the old global properties file to the new one.

2017-06-21 00:00:00,121 INFO [org.alfresco.repo.security.sync.ChainingUserRegistrySynchronizer] [DefaultScheduler_Worker-4] Synchronizing users and groups with user registry 'ldap1'
2017-06-21 00:00:00,123 WARN [org.alfresco.repo.security.sync.ChainingUserRegistrySynchronizer] [DefaultScheduler_Worker-4] Full synchronization with user registry 'ldap1'
2017-06-21 00:00:00,131 WARN [org.alfresco.repo.security.sync.ChainingUserRegistrySynchronizer] [DefaultScheduler_Worker-4] Some users and groups previously created by synchronization with this user
registry may be removed.
2017-06-21 00:00:00,184 INFO [org.alfresco.repo.security.sync.ChainingUserRegistrySynchronizer] [DefaultScheduler_Worker-4] Retrieving all groups from user registry 'ldap1'
2017-06-21 00:00:00,241 ERROR [org.alfresco.repo.security.sync.ChainingUserRegistrySynchronizer] [DefaultScheduler_Worker-4] Synchronization aborted due to error
org.alfresco.error.AlfrescoRuntimeException: 05213109 Error during LDAP Search. Reason:domain:389

Issue #2: Unable to update tag scopes. I'm not really sure what this one means. The error appears in the logs exactly every two hours.

2017-06-21 00:55:45,151 ERROR [org.quartz.core.JobRunShell] [DefaultScheduler_Worker-9] Job DEFAULT.
taggingStartupJobDetail threw an unhandled Exception: java.lang.RuntimeException: Unable to update the tag scopes.
at org.alfresco.repo.tagging.UpdateTagScopesActionExecuter.executeImpl(UpdateTagScopesActionExecuter.java:295)...

Caused by: org.alfresco.error.AlfrescoRuntimeException: 05213420 Node type is not recognised: {http:
//www.alfresco.org/model/website/1.0}websiteContainer

If anyone has insight or ideas on these issues, your input is greatly appreciated.

1 Reply
Highlighted
Customer

Re: Some Post-Upgrade Issues 4.2.c to 5.2.0

Hi:

1) I suppose that in the given logs you change you real domain. Do you ?

Error during LDAP Search. Reason:domain:389

 

If not something is probably wrong in the config, or all properties were not set. Anyway you may set:

log4j.logger.org.alfresco.repo.security.sync=debug

2) The second error seems due a model type not defined in the new version of Alfresco - missed, or maybe related with WCM (awe.war) in old version ? 

Caused by: org.alfresco.error.AlfrescoRuntimeException: 05213420 Node type is not recognised: {http:
//www.alfresco.org/model/website/1.0}websiteContainer

Regards.

--C.