SSL using letsencrypt/AWS certificate in AWS alfresco community instance

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Senior Member

SSL using letsencrypt/AWS certificate in AWS alfresco community instance

I have done SSL in a testing environment with certificate purchased from third-party vendor. It was successfully done as per the steps are given in the doc. Configuring SSL for a test environment | Alfresco Documentation 

But, I am facing a problem in implementing SSL in a production environment. (linux)

I have tried with nginx and httpd both.

1. I have to use AWS load balancer with SSL(using Aws certificate) to handle the https request and redirect it to Alfresco server. (done)

2. Alfresco part (repo) is working well with the secured green symbol in the URL but https://myserver/share is not.

3. Share does not allow login, it is redirecting to /dologin page and shows something wrong with this page.

If anyone has done this before, then pls help.

Kintu

Regards,
Kintu | ContCentric
2 Replies
Customer

Re: SSL using letsencrypt/AWS certificate in AWS alfresco community instance

Hi:

I do not see why do you need to use AWS load balancer or change Alfresco SSL certificates. 

The simplest aprox is to configure an apache httpd (or nginx) virtual host in 443 and to use letsencrypt certbot for getting the certificates of your public machine. In the virtualhost, you should proxy /alfresco and /share to the tomcat ports (via http or ajp). You do not need to touch Alfresco config for this, a usual aprox is to secure only the frontend. You may disable 8080 connector and do proxypass via ajp to 8009 port too.

Regards.

--C.

Highlighted
Active Member

Re: SSL using letsencrypt/AWS certificate in AWS alfresco community instance


Hi cesarista,
The Alfresco Content Services application does not communicate with sites that have the ssl protocol.
I installed Let's Encrypt on a website.
Sites with http connects normally
When trying to connect through the application, the following error message occurs:

Save Account
Couldn't save account. Check your account settings with your IT Team
Retry with diagnostic
Done

Clicking on Retry with diagnosis.
Go through the steps with the exception of Checking repository connection

Any configuration to be done?
Thank you.
José Roberto.