Strange Http11Processor error

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Established Member II

Strange Http11Processor error

Hello

Once in a few days, my Alfresco instance is self restarting. When I enter logs, there is almost every time the same log sequence before restart:

 01-Sep-2020 20:16:30.032 INFO [http-nio-8080-exec-21] org.apache.coyote.http11.Http11Processor.service Error parsing HTTP request header
 Note: further occurrences of HTTP request parsing errors will be logged at DEBUG level.
        java.lang.IllegalArgumentException: Invalid character found in method name [0x050x040x000x010x020x800x050x010x000x030x0agithub.com0x00PGET]. HTTP method names must be tokens
                at org.apache.coyote.http11.Http11InputBuffer.parseRequestLine(Http11InputBuffer.java:418)
                at org.apache.coyote.http11.Http11Processor.service(Http11Processor.java:260)
                at org.apache.coyote.AbstractProcessorLight.process(AbstractProcessorLight.java:65)
                at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:868)
                at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1589)
                at org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49)
                at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
                at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
                at java.lang.Thread.run(Thread.java:748)

I have an SSL enabled (Let's Encrypt), it works every day.

The java.lang.IllegalArgumentException is always like: "Invalid character found in xxx".

After that, servers stop and after that, there are again errors:

01-Sep-2020 00:24:23.304 WARNING [Thread-52] org.apache.catalina.loader.WebappClassLoaderBase.clearReferencesThreads The web application [alfresco] appears to have started a thread named [Timer-3] but has failed to stop it. This is very likely to create a memory leak. Stack trace of thread:
 java.lang.Object.wait(Native Method)
 java.lang.Object.wait(Object.java:502)
 java.util.TimerThread.mainLoop(Timer.java:526)
 java.util.TimerThread.run(Timer.java:505)

And after that bunch of severe logs:

01-Sep-2020 00:24:23.336 SEVERE [Thread-52] org.apache.catalina.loader.WebappClassLoaderBase.checkThreadLocalMapForLeaks The web application [alfresco] created a ThreadLocal with key of type [java.lang.ThreadLocal.SuppliedThreadLocal] (value [java.lang.ThreadLocal$SuppliedThreadLocal@792a15aa]) and a value of type [org.alfresco.util.transaction.TransactionSupportUtil.ResourcesHolder] (value [org.alfresco.util.transaction.TransactionSupportUtil$ResourcesHolder@1d82ab84]) but failed to remove it when the web application was stopped. Threads are going to be renewed over time to try and avoid a probable memory leak.

And Alfresco starts again, as nothing happened..
 

Is it a Let's encrypt error? Config error? Hackers?

1 Reply
Highlighted
Established Member II

Re: Strange Http11Processor error

I created a new server with a new IP address, new certificates - still the same error. What can be wrong?