Unable to install sdk version

cancel
Showing results for 
Search instead for 
Did you mean: 
rkhot
Member II

Unable to install sdk version

HI Team,

I am trying to install Alfresco SDK version using this link :

https://docs.alfresco.com/content-services/6.0/develop/sdk/#gettingstarted

I am getting below error when tryig to run "run.bat build_start" for the first time.

 

my-all-in-one>run.bat build_start
[INFO] Scanning for projects...
Downloading from alfresco-public: https://artifacts.alfresco.com/nexus/content/groups/public/org/alfresco/acs-community-packaging/7.0....
Downloading from alfresco-public-snapshots: https://artifacts.alfresco.com/nexus/content/groups/public-snapshots/org/alfresco/acs-community-pack...
Downloading from alfresco-private-repository: https://artifacts.alfresco.com/nexus/content/groups/private/org/alfresco/acs-community-packaging/7.0...
Downloading from central: https://repo.maven.apache.org/maven2/org/alfresco/acs-community-packaging/7.0.0/acs-community-packag...
[ERROR] [ERROR] Some problems were encountered while processing the POMs:
[ERROR] Non-resolvable import POM: Could not transfer artifact org.alfresco:acs-community-packagingSmiley Tongueom:7.0.0 from/to alfresco-public (https://artifacts.alfresco.com/nexus/content/groups/public): transfer failed for https://artifacts.alfresco.com/nexus/content/groups/public/org/alfresco/acs-community-packaging/7.0.... @ line 489, column 19
[ERROR] 'dependencies.dependency.version' for junit:junit:jar is missing. @ line 250, column 17
[ERROR] 'dependencies.dependency.version' for org.apache.httpcomponents:httpclient:jar is missing. @ line 316, column 17
[ERROR] 'dependencies.dependency.version' for org.alfresco:alfresco-remote-api:jar is missing. @ line 352, column 17
@
[ERROR] The build could not read 1 project -> [Help 1]
[ERROR]
[ERROR] The project com.acme:my-all-in-one:1.0-SNAPSHOT (C:\Users\rahul_khot\my-all-in-one\pom.xml) has 4 errors
[ERROR] Non-resolvable import POM: Could not transfer artifact org.alfresco:acs-community-packagingSmiley Tongueom:7.0.0 from/to alfresco-public (https://artifacts.alfresco.com/nexus/content/groups/public): transfer failed for https://artifacts.alfresco.com/nexus/content/groups/public/org/alfresco/acs-community-packaging/7.0.... @ line 489, column 19: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target -> [Help 2]
[ERROR] 'dependencies.dependency.version' for junit:junit:jar is missing. @ line 250, column 17
[ERROR] 'dependencies.dependency.version' for org.apache.httpcomponents:httpclient:jar is missing. @ line 316, column 17
[ERROR] 'dependencies.dependency.version' for org.alfresco:alfresco-remote-api:jar is missing. @ line 352, column 17
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
[ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException
my-all-in-one-acs-volume
my-all-in-one-db-volume
my-all-in-one-ass-volume
ERROR: .FileNotFoundError: [Errno 2] No such file or directory: 'C:\\Users\\rahul_khot\\my-all-in-one\\target\\classes\\docker\\docker-compose.yml'
ERROR: .FileNotFoundError: [Errno 2] No such file or directory: 'C:\\Users\\rahul_khot\\my-all-in-one\\target\\classes\\docker\\docker-compose.yml'Capture.JPG

1 Reply
abhinavmishra14
Advanced

Re: Unable to install sdk version

For ACS 7, you should be using sdk 4.2: https://docs.alfresco.com/content-services/latest/develop/sdk/

Make sure Java11 installed and maven-3.3.xx or later is installed and configured in the environment variables. 

Some useful details can be found here: https://github.com/Alfresco/alfresco-sdk/blob/master/docs/getting-started.md

Also make sure that maven settings file is correct and credentials for priavate repo is setup if you are planning to use enterprise version. see sample settings.xml below.

<?xml version="1.0" encoding="UTF-8"?>
<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"  xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0 http://maven.apache.org/xsd/settings-1.0.0.xsd">
	<!-- Default: ${user.home}/.m2/repository -->
	<!--<localRepository>C:\Maven\repository</localRepository>-->
	
	<pluginGroups>
		<pluginGroup>net.thucydides.maven.plugins</pluginGroup>
	</pluginGroups>
	
	<servers>		
		<server>
			<id>alfresco-public</id>
			<username>yourusername</username>
			<password>yourpassword</password>
		</server>
		<server>
			<id>alfresco-private-repository</id>
			<username>yourusername</username>
			<password>yourpassword</password>
		</server>
		<server>
			<id>alfresco-public-snapshots</id>
			<username>yourusername</username>
			<password>yourpassword</password>
		</server>
		<server>
			<id>alfresco-plugin-public</id>
			<username>yourusername</username>
			<password>yourpassword</password>
		</server>
		<server>
			<id>alfresco-plugin-public-snapshots</id>
			<username>yourusername</username>
			<password>yourpassword</password>
		</server>
	</servers>

	<profiles>	
		<profile>
			<id>alfresco</id>
			<activation>
				<activeByDefault>true</activeByDefault>
			</activation>
			<repositories>
				<repository>
					<id>central</id>
					<url>https://repo1.maven.org/maven2/</url>
					<releases>
						<enabled>true</enabled>
					</releases>
					<snapshots>
						<enabled>true</enabled>
					</snapshots>
				</repository>
				<repository>
					<id>alfresco-private-repository</id>
					<url>https://artifacts.alfresco.com/nexus/content/groups/private/</url>
					<releases>
						<enabled>true</enabled>
					</releases>
					<snapshots>
						<enabled>false</enabled>
					</snapshots>
				</repository>
				<repository>
					<id>alfresco-public</id>
					<url>http://maven.alfresco.com/nexus/content/groups/public/</url>
					<releases>
						<enabled>true</enabled>
					</releases>
					<snapshots>
						<enabled>true</enabled>
					</snapshots>
				</repository>
				<repository>
					<id>alfresco-public-snapshots</id>
					<url>https://artifacts.alfresco.com/nexus/content/groups/public-snapshots</url>
					<snapshots>
						<enabled>true</enabled>
						<updatePolicy>daily</updatePolicy>
					</snapshots>
				</repository>
			</repositories>
			<pluginRepositories>
				<pluginRepository>
					<id>central</id>
					<url>https://repo1.maven.org/maven2/</url>
					<releases>
						<enabled>true</enabled>
					</releases>
					<snapshots>
						<enabled>true</enabled>
					</snapshots>
				</pluginRepository>
				<pluginRepository>
					<id>alfresco-public</id>
					<url>http://maven.alfresco.com/nexus/content/groups/public/</url>
					<releases>
						<enabled>true</enabled>
					</releases>
					<snapshots>
						<enabled>true</enabled>
					</snapshots>
				</pluginRepository>
				<pluginRepository>
					<id>alfresco-plugin-public</id>
					<url>https://artifacts.alfresco.com/nexus/content/groups/public</url>
				</pluginRepository>
				<pluginRepository>
					<id>alfresco-plugin-public-snapshots</id>
					<url>https://artifacts.alfresco.com/nexus/content/groups/public-snapshots</url>
					<snapshots>
						<enabled>true</enabled>
						<updatePolicy>daily</updatePolicy>
					</snapshots>
				</pluginRepository>
				<pluginRepository>
					<id>alfresco-private-repository</id>
					<url>https://artifacts.alfresco.com/nexus/content/groups/private</url>
				</pluginRepository>
			</pluginRepositories>
		</profile>
	</profiles>
	<activeProfiles>
		<activeProfile>alfresco</activeProfile>
	</activeProfiles>
</settings>

Also i see this error: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

Try to clean your maven repo or install certs if a clean up also fails:

https://github.com/abhinavmishra14/InstallCert#readme

~Abhinav
(ACSCE, AWS SAA, GAIQ)