Unable to login to Share

Showing results for 
Search instead for 
Did you mean: 

Unable to login to Share

I upgraded from ACS 5.2 to  ACS 7.2. ACS is up and running. I am unable to login to share. It says: 

DEBUG [org.alfresco.web.site.servlet.SSOAuthenticationFilter] [http-nio-8080-exec-3] There is no endpoint with external auth enabled.
INFO [org.alfresco.web.site.EditionInterceptor] [http-nio-8080-exec-3] Unable to retrieve License information from Alfresco: 404

I have studied a post we had regarding this but the fix suggested is not working. Any clue on it would be greatly appreciated.


4 Replies

Re: Unable to login to Share

I would focus on the first one that says "there is no endpoint with external auth enabled." This might be adding to the later error. 

Looks like you have external authentication enabled. I would suggest to disable it first. Use default alfrescoNtlm for testing and when you feel like everything is working as expected, switch on the external auth and then re-test.

Visit this documentation for more details: 



On the second part, i am not sure if you applied the license correctly as subsystem is unable to locate your license file. 

There are multiple ways you can update your license.

1- Via Repository admin console : https://docs.alfresco.com/content-services/latest/admin/license/#uploadlicense (No restart needed)

2- Copy the license file to $ALF_INTALL_DIRECTORY/licenses (restart needed)

3- Copy the license file to $ALF_INTALL_DIRECTORY/tomcat/webapps/alfresco/WEB-INF/licenses (restart needed)

4- Copy the license file to $ALF_INTALL_DIRECTORY/tomcat/shared/classes/alfresco/extension (restart needed)

If license file is applied successfully , the ".lic" file is automatically renamed to "<license-name>.lic.installed"

Additonal details can be found at: https://docs.alfresco.com/content-services/latest/admin/license/


- Couple of other things to check, make sure "alfresco-share-services" amp matching to the latest version is applied correctly on alfresco.war (be sure to delete the exploded war if yet to apply the amp). Also check if repository-url is correctly configured in share-config-custom.xml.

- This error even comes when share is up and alfresco has crashed or erroring out for any reason. So take a deep look at alfresco.log, catalina.out to see if you can spot anything. 

- If you are using SSL (mTls), make sure keystore files are copied and mapped appropriately. 

- Lastly, always verify if the license file (if copied to a directory manually) is readable (read access). 


(ACSCE, AWS SAA, Azure Admin)

Re: Unable to login to Share

Thanks for response Abhinav..

External auth is already disabled.

I have placed license to $TOMCAT_DIR/webapps/alfresco/WEB-INF/classes/alfresco/extension/license/ using Dockerfile.

I confirmed from logs that license is applied: INFO [org.alfresco.enterprise.license.AlfrescoLicenseManager] [main] Successfully installed license from file [/usr/local/tomcat/webapps/alfresco/WEB-INF/classes/alfresco/extension/license/...

I tirggered this url that EditionInterceptor.class uses to retrieve license info in share: 

curl -X GET http://alfresco:8080/alfresco/s/api/admin/restrictions?guest=true     

It gives response:

[root@4e7617df5d84 tomcat]# curl -X GET http://alfresco:8080/alfresco/s/api/admin/restrictions?guest=true
"lastUpdate" : 1654888636491,
"users" : 1000,
"documents" : null,
"licenseMode" : "ENTERPRISE",...

This is share docker compose config:

image: share-jar:latest
mem_limit: 1g
REPO_HOST: "alfresco"
REPO_PORT: "8080"
- "8080:8080"
- "5006:8000"

Still when I try to login it fails with same error: Unable to retrieve License information from Alfresco: 404


Re: Unable to login to Share

I found what the issue was:

Repository url was <repository-url>http://localhost:8080/alfresco</repository-url> instead of <repository-url>http://alfresco:8080/alfresco</repository-url>. 

So share was finally able to construct http://alfresco:8080/alfresco/s/api/admin/restrictions?guest=true url for getting license info and it worked.

Thanks for looking into it Abhinav appreciate it.


Re: Unable to login to Share

Glad to hear that you are able to resolve the issue

(ACSCE, AWS SAA, Azure Admin)