Upgrade from 4.2 to 6.1 | Please follow an incremental upgrade using version 5.2.x.

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member II

Upgrade from 4.2 to 6.1 | Please follow an incremental upgrade using version 5.2.x.

Jump to solution

Hi,

try to upgrade vom 4.2 to 6.1, but there is a problem with patch.db-v4.2-migrate-activiti-workflows.

Is there any way to fix this issue (we do not need workflows)?

=====================================
2020-07-29 14:13:58,482 ERROR [org.alfresco.repo.admin.patch.PatchExecuter] [localhost-startStop-1] 
=== Failed to apply patch         === 
ID: patch.db-v4.2-migrate-activiti-workflows
RESULT: 
06290018 
Patch 'patch.db-v4.2-migrate-activiti-workflows' was last supported on version 5.2.x.
   Please follow an incremental upgrade using version 5.2.x. 
=====================================
2020-07-29 14:13:58,483 ERROR [org.springframework.web.context.ContextLoader] [localhost-startStop-1] Context initialization failed
org.alfresco.error.AlfrescoRuntimeException: 06290019 Not all patches could be applied

 

1 Solution

Accepted Solutions
Highlighted
Community Manager
Community Manager

Re: Upgrade from 4.2 to 6.1 | Please follow an incremental upgrade using version 5.2.x.

Jump to solution

Hi @samuelw,

Alfresco partner Keensoft have some useful blogs on upgrading Alfresco - 4.2.c-5.0.c,  &  5 to 6 considerations., and their upgrade process for 5-6. Here's Angel Borroy's slidedeck on migration. Concentric have also written a 5-6 upgrade guide.

HTH

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!

View solution in original post

4 Replies
Highlighted
Moderator
Moderator

Re: Upgrade from 4.2 to 6.1 | Please follow an incremental upgrade using version 5.2.x.

Jump to solution

As the warning suggests, you can't upgrade from 4.2 to 6.x directly with everything successfully working. There may be incompatiblities involved, that's why it is recommended to do incremental upgrade. Ideally from 4.2.x to 5.2.x and then 6.x

From version below 5.2.x UpgradePath to 5.x

From 5.x UpgradePath to ACS6.x

Community version UpgradePath to ACS6.x

~Abhinav
(ACSCE, AWS SAA-C02, GAIQ)
Highlighted
Community Manager
Community Manager

Re: Upgrade from 4.2 to 6.1 | Please follow an incremental upgrade using version 5.2.x.

Jump to solution

Hi @samuelw,

Alfresco partner Keensoft have some useful blogs on upgrading Alfresco - 4.2.c-5.0.c,  &  5 to 6 considerations., and their upgrade process for 5-6. Here's Angel Borroy's slidedeck on migration. Concentric have also written a 5-6 upgrade guide.

HTH

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!

View solution in original post

Highlighted
Active Member II

Re: Upgrade from 4.2 to 6.1 | Please follow an incremental upgrade using version 5.2.x.

Jump to solution

Works perfect, thank you.

Highlighted
Community Manager
Community Manager

Re: Upgrade from 4.2 to 6.1 | Please follow an incremental upgrade using version 5.2.x.

Jump to solution

Hi @samuelw,

Glad it worked for you & thanks for accepting the solution - helpful to other users.

All the best, 

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!