Upgrade Path 5.0.b to 6.2 docker

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Upgrade Path 5.0.b to 6.2 docker

Hello,

I am currently on (a somehow broken) installation of 5.0.b community and would like to move to a new community installation. I would prefer to use the latest version in a docker-compose deployment, but would use anything else, as long as it is working.

I managed to install and start the current version using the docker-compose.yml from GitHub, but the import of the data from the old system failed. I guess, the database somehow changed between those version.

What is the path to upgrade from 5.0.b to the latest version? I read, that at least 5.2 is required as an intermediate step, but I am not sure about this.

I tried following this guide and it work well up to the import of the old data. That broke something, so that some of the docker containers did not start anymore.

I thank you in advance for any help

5 Replies
Highlighted
Alfresco Employee

Re: Upgrade Path 5.0.b to 6.2 docker

I guess you need to upgrade first to 6.0 and from that point to 6.2

Software Engineer in Alfresco Search Team.
Highlighted
Member II

Re: Upgrade Path 5.0.b to 6.2 docker

Hey,

thanks for your reply. I managed to upgrade to 5.2, but I am unable to import the backup into 6.0.

I have a dump of the postgresql database and a copy of the alf_data folder. Do I need anything else?

Thanks again for your time and effort!

Established Member II

Re: Upgrade Path 5.0.b to 6.2 docker

Here Alfresco states that you can directly upgrade from 5.2 to 6.0, but upgrading alfresco-search-services first. What errors are you getting?

 

Highlighted
Alfresco Employee

Re: Upgrade Path 5.0.b to 6.2 docker

You don't need anything else. What means "unable to import" the backup? You need to restore the dump of PostgreSQL and to copy the alf_data folder.

Software Engineer in Alfresco Search Team.
Highlighted
Member II

Re: Upgrade Path 5.0.b to 6.2 docker

I did not manage to import the postgres dump. After some more tries, I finally succeeded. I am now on 6.0, but did not manage the upgrade to 6.2 by reusing the existing docker volumes from 6.0. I do not know, what changed between the versions, maybe the user in the containers, so the files in alf_data are not accessible after the update.

For now, I am satisfied with this, as we have a working setup now.

Thanks for your time, and especially thanks for your blog posts and example configurations. They helped a lot along the way!