Upgrading alfresco 201605 - Cannot find Alfresco Repository

Showing results for 
Search instead for 
Did you mean: 
Member II

Upgrading alfresco 201605 - Cannot find Alfresco Repository


some time i 2016 I have installed Alfresco 201605 on Windows server. Last few days I have really been struggling to upgrade it to some newer version (I have tried 201612 and 201707). Can you please tell me, what am I doing wrong?

My checklist:

-stop tomcat

-backup alf_data

-backup postgresql database "alfresco" (using handy backup 8)

-uninstall old alfresco

-install new version (setting the same administrative password as in the old one)

-start postgresql and restore the "alfresco" database

-restore folders contentstore, contentstore.deleted, solr4 and solr4backup from backup to new Alfresco\alf_data (alfresco-global.properties is pointing to this correct alf_data location)

-start tomcat

Opening Alfresco in browser then displays error "Cannot find Alfresco Repository on this server. (Does this application have access to alfresco-global.properties? Does this application have cross-context permissions?).

When I tried the same procedure to migrate data from 201605 to a newly installed 201605 it worked. But it does not work with newer version. It looks like the contentstore is not recognized by different version than the one I am on.

Please advise.

Thank you

Best Regards


2 Replies

Re: Upgrading alfresco 201605 - Cannot find Alfresco Repository

Can you provide any log files? The message "Cannot find Alfresco Repository on this server" is a very generic one, that appears whenever Share cannot connect / work with the backend, but that can be for myriads of reasons. We would need to look into the alfresco.log / share.log / catalina.out files for any details.

Member II

Re: Upgrading alfresco 201605 - Cannot find Alfresco Repository

yes, ofcourse, logs are here https://gdata-my.sharepoint.com/:f:/g/personal/wessnitzer_g-data_cz/ElwD3Db26KpJsYAJEMgs6QQBFPjljiou... 
Looking at them, problem seems to be "CONTENT INTEGRITY ERROR: System content not found in content store."
Searching points me into direction, that perhaps the database is "desynchronized" from the store. I am gonna try DB backup and restore in different way. I am not sure if I shoul back up and restore both "alfresco" and "postgres" databases, or just "alfresco" (i did just alfresco).