Warning while integrating alfresco with eclipse

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
lipsa
Active Member

Warning while integrating alfresco with eclipse

I had created a share extension project in eclipse using alfresco-amp-archetype and build is also successful. But I am getting a warning " [WARNING] The requested profile "amp-to-war" could not be activated because it does not exist. "

How to tackle it now?

7 Replies
mehe
Senior Member II

Re: Warning while integrating alfresco with eclipse

SDK/Alfresco version is?

Did you use

 mvn install -Pamp-to-war

At least for Alfresco community 5.1 and the corresponding sdk it should work:

Maven Archetypes - Command Reference | Alfresco Documentation 

lipsa
Active Member

Re: Warning while integrating alfresco with eclipse

I have tried it now, but still it's giving the same warning.

mehe
Senior Member II

Re: Warning while integrating alfresco with eclipse

...and your Alfresco version is?   SDK version is?   

lipsa
Active Member

Re: Warning while integrating alfresco with eclipse

Alfresco Version : 5.2.0

SDK Version : 2.2.0

mehe
Senior Member II

Re: Warning while integrating alfresco with eclipse

I'm not sure if that is a valid combination (maybe Axel Faust‌ could comment on this) 

config check like Upgrading SDK 2.2.0 projects from Community 5.1.e to 5.2.a | Alfresco Documentation

afaust
Master

Re: Warning while integrating alfresco with eclipse

Alfresco has intended for SDK 3 to be the official SDK version for Alfresco 5.2, but unfortunately they did not manage to properly release it in time. A beta has been available since middle of last year. As far as I know, SDK 2.2 can generally be made to work with Alfresco 5.2. Personally, I do not use the SDK myself so the experience / list of suggestions is very limited.

mehe
Senior Member II

Re: Warning while integrating alfresco with eclipse

...and it just arrived today Smiley Happy see