Web script status 404 when searching files in whitepapers

cancel
Showing results for 
Search instead for 
Did you mean: 
YanFeiHu
Member II

Web script status 404 when searching files in whitepapers

Hi Team;

     Please refer the picture as below, when I running the AIO project, the Web Script has responded with a status of 404.

     Could you please check the problem for me?

     Thanks a lot.

     The URL as follow;

     "https://ecmarchitect.com/alfresco-developer-series-tutorials/webscripts/tutorial/tutorial.html"

not found.png

1 Reply
abhinavmishra14
Advanced

Re: Web script status 404 when searching files in whitepapers

Looks like you have not deployed the webscript. 

You need to deploy the webscripts to any of the following locations:

- Data Dictionary > Web Scripts Extensions (/Company Home/Data Dictionary/Web Scripts Extensions)

- Data Dictionary > Web Scripts (/Company Home/Data Dictionary/Web Scripts)

This is clearly mentioned in the tutorial. https://ecmarchitect.com/alfresco-developer-series-tutorials/webscripts/tutorial/tutorial.html#hello...

If webscripts are in folder structure e.g. com\someco\whitepapers, then upload the "com" folder all together to the any of the above folders. Your uploaded webscript path would be like: Data Dictionary > Web Scripts Extensions > com > someco > whitepapers

Once you are done with upload, refresh the webscripts so they get loaded. Use the following url: 

http://127.0.0.1:8080/alfresco/s/index

Click on "Refresh Web Scripts" button after you logged in.

Refer this doc for in detail info: https://docs.alfresco.com/content-services/5.2/tutorial/platform/web-scripts/

 

 

 

~Abhinav
(ACSCE, AWS SAA, Azure Admin)