Activiti 6.0.0 bugs and production environment

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Activiti 6.0.0 bugs and production environment

Hello.

I'm new to Activiti.

At the company I work for, we are attempting to adopt it.

I'm watching at this tutorial to understand how the product works (I'm aware enough of what BPMN is): https://www.youtube.com/watch?v=V1wrew-YgfA&feature=youtu.be

I've downloaded and installed the 6.0.0 Activiti version.

Following the tutorial, I found myself faced with some problem.

So, I have to ask:

  • supposing all issues I've encountered are Activiti 6.0.0 bugs, does Alfresco plan to fix them?
  • or, is Activiti "6.0.0" abandoned / no longer supported?
  • is Activiti "6.0.0" suitable for production use, or it is just for experimenting?
  • If you want to go deep with things that caused me problems, you can read the details below.


Thanks.


---- DETAILS ----


FORMS: MISSING WIDGETS

The tutorial uses the "Display Value" and the "Display Text" for some form.

But I can't found them.

Probably this is because the tutorial is about the "6.0.0 beta 2", instead of "6.0.0" I'm using.

Anyway, I guess that both widgets have been replaced by the "Expression" widget (is this correct?).

But.

As you can see at 16:56, a specific id is assigned to the "Display Text" form field: sadly, "Override id?" and "id" elements are not available for the "Expression" widget.

So, if the "Expression" widget has replaced the "Display Value" and the "Display Text", how to specify the "id" when it is required?


FORMS: "PEOPLE" WIDGET REQUIRED FIELD

Back to the tutorial, at 8:31 a "People" widget is added to the form "demande de double correction" as the field "Enseignant Responsable" (direct link to 8:31 https://youtu.be/V1wrew-YgfA?t=511 ).

The field is flagged as "Required".

Jumping to 28:09 you can see how the user fills up the required field.
When I start the process and try to do the same, it works exactly in the same way.

But.

When I click "Start process" an error bar is displayed preventing the process to proceed.
To discover where is the problem, I' had to watch at Tomcat localhost.*.log logfile, and this is what I've found:

26-Jun-2019 16:09:10.231 SEVERE [http-nio-6060-exec-1] org.apache.catalina.core.StandardWrapperValve.invoke Servlet.service() for servlet [appDispatcher] in context with path [/activiti-app] threw exception [Request processing failed; nested exception is org.activiti.form.engine.ActivitiFormValidationException: Form field enseignantresponsable is required, but no value was found] with root cause
org.activiti.form.engine.ActivitiFormValidationException: Form field enseignantresponsable is required, but no value was found
[...]

It says that "field enseignantresponsable is required, but no value was found", yet the field is filled up.

Does the version "6.0.0" Actviti's "People" widget affected by some bug?

CREATE APP AND CUSTOMIZATION

At 26:05 (direct link https://youtu.be/V1wrew-YgfA?t=1565 ) an App is created, and the person who creates it chose to use a different icon (which depict a "highway" instead of the "asterisk").

Publishing the App (27.03, direct link https://youtu.be/V1wrew-YgfA?t=1623 ), the published App is depicted with the chosen icon (the "highway").

I've tried to do the same, but, in my case, the App icon is the same of "Kickstart App", and also the background theme/color is the same, regardless of the icon and theme/color I choose.

1 Reply
Highlighted
Moderator
Moderator

Re: Activiti 6.0.0 bugs and production environment

I suggest to use Activiti 5.22, it is the latest stable and production ready version and consider that this version is also included in Alfresco Process Services 1.x. Hope this helps Smiley Happy