Activiti projet deployement

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

Activiti projet deployement

Jump to solution

Hello,

to deploy my project using activiti 5.22, I copied .jar file to webapps\activiti-explorer\WEB-INF\lib. But when I restart Tomcat, activiti-explorer resets, so all my users and groups are removed. And every time I stop tomcat and restart it I have to redo everything again.

I read in some forums that I have to copy .jar to "webapps\activiti-explorer\WEB-INF\lib" and "webapps\activiti-rest\WEB-INF\lib" But I don't see activiti-rest in tomcat folder. 

So, what should I do ?

Many thanks

1 Solution

Accepted Solutions
Highlighted
Senior Member

Re: Activiti projet deployement

Jump to solution

Since H2 is not production ready, we recommend using other databases.


But, if you really want to use H2, change the setting as follows.
activiti-explorer/WEB-INF/classes/db.properties

  • Before fix

jdbc.url=jdbc:h2:mem:activiti;DB_CLOSE_DELAY=1000

  • After fix

jdbc.url=jdbc:h2:file:activiti;DB_CLOSE_DELAY=1000

View solution in original post

4 Replies
Highlighted
Alfresco Employee

Re: Activiti projet deployement

Jump to solution

Sounds like maybe you are using in-memory h2 database. Perhaps look at  

Active Member

Re: Activiti projet deployement

Jump to solution

Thanks, But the problem is that I'am using H2 database in my project

Highlighted
Senior Member

Re: Activiti projet deployement

Jump to solution

Since H2 is not production ready, we recommend using other databases.


But, if you really want to use H2, change the setting as follows.
activiti-explorer/WEB-INF/classes/db.properties

  • Before fix

jdbc.url=jdbc:h2:mem:activiti;DB_CLOSE_DELAY=1000

  • After fix

jdbc.url=jdbc:h2:file:activiti;DB_CLOSE_DELAY=1000

View solution in original post

Highlighted
Active Member

Re: Activiti projet deployement

Jump to solution

Thank you so much, you saved my life( (y)