Activiti random behaviour

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

Activiti random behaviour

Jump to solution

I'm creating a process instance as such:

processInstance = runtimeService.startProcessInstanceByKeyAndTenantId(key, initialParameters, tenantId + (isTest ? TEST_TENANT_SUFFIX : PRODUCTION_TENANT_SUFFIX));

which always returns a processInstance, but sometimes(seemingly randomly) the returned process instance does not exist in the database:

historyService.createHistoricProcessInstanceQuery().processInstanceId(processInstance.getId()).singleResult() == null

runtimeService.createProcessInstanceQuery().processInstanceId(processInstance.getId()).singleResult() == null

I've also logged the mariadb queries and I've noticed that the times that the instance does not exist; no insert queries are logged in the database, so the process instance was not inserted and then deleted.

these problems started appearing after migrating to activiti6

1 Solution

Accepted Solutions
Highlighted
Active Member

Re: Activiti random behaviour

Jump to solution

After a lot of debugging I discovered that Activiti's command context was being manipulated in my code, which was causing the random behavior.

View solution in original post

2 Replies
Highlighted
Active Member

Re: Created process instance not found

Jump to solution

Also, I'm using activiti-spring-boot-starter-basic

Highlighted
Active Member

Re: Activiti random behaviour

Jump to solution

After a lot of debugging I discovered that Activiti's command context was being manipulated in my code, which was causing the random behavior.

View solution in original post