Activiti supports grails?

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Established Member

Activiti supports grails?

Hi Team,

I would like to use activiti framework in my grails application. Is activiti supports grails?

if yes, please let me know how to configure this.

Thanks

4 Replies
Highlighted
Established Member

Re: Activiti supports grails?

Hi,

I have not tried this but there is plugin available, you can check this link Grails Plugin: Grails Activiti Plugin - Enabled Activiti BPM Suite support for Grails  This link is quite old.

See if this can help you.

Regards,

Rupesh

EnProwess Technologies

Established Member

Re: Activiti supports grails?

Thank you for your reply. I tried this one. Errors are coming when project is running.

Highlighted
Senior Member

Re: Activiti supports grails?

You should probably try to explain the errors or try to contact the author of that plugin and explain the errors. Look at his/her github account -> Issues · limcheekin/activiti · GitHub  and the issues reported. You have the source in there.. so you might want to try to fix the problem and send a pull request. 

Highlighted
Established Member

Re: Activiti supports grails?

Hi,

I follow the given link as follows How to build our own workflow system using the Grails Activiti plugin - Stack Overflow 

when i put the plugin in my build config then it is showing errors as like as below.

Loading Grails 2.4.4
|Configuring classpath
|Downloading: org/activiti/activiti-engine/5.13/activiti-engine-5.13.pom
|Downloading: org/activiti/activiti-root/5.13/activiti-root-5.13.pom
|Downloading: org/activiti/activiti-bpmn-converter/5.13/activiti-bpmn-converter-5.13.pom
|Downloading: org/activiti/activiti-bpmn-model/5.13/activiti-bpmn-model-5.13.pom
|Downloading: org/codehaus/jackson/jackson-core-asl/1.9.9/jackson-core-asl-1.9.9.pom
|Downloading: org/mybatis/mybatis/3.2.2/mybatis-3.2.2.pom
|Downloading: org/mybatis/mybatis-parent/18/mybatis-parent-18.pom
|Downloading: org/mybatis/mybatis/3.2.2/mybatis-3.2.2.jar
|Downloading: org/codehaus/jackson/jackson-core-asl/1.9.9/jackson-core-asl-1.9.9.jar
|Downloading: org/activiti/activiti-bpmn-converter/5.13/activiti-bpmn-converter-5.13.jar
|Downloading: org/activiti/activiti-bpmn-model/5.13/activiti-bpmn-model-5.13.jar
Error |
Resolve error obtaining dependencies: Could not find artifact org.activiti:activiti-engine:zip:5.13 in grailsCentral (https://repo.grails.org/grails/plugins) (Use --stacktrace to see the full trace)
Error |
Resolve error obtaining dependencies: Could not find artifact org.activiti:activiti-engine:zip:5.13 in grailsCentral (https://repo.grails.org/grails/plugins) (Use --stacktrace to see the full trace)
Error |
Resolve error obtaining dependencies: Could not find artifact org.activiti:activiti-engine:zip:5.13 in grailsCentral (https://repo.grails.org/grails/plugins) (Use --stacktrace to see the full trace)
Error |
Could not find artifact org.activiti:activiti-engine:zip:5.13 in grailsCentral (https://repo.grails.org/grails/plugins)
|Run 'grails dependency-report' for further information.

Please help me out how to resolve this.