activiti with spring boot 2.1 or 2.2?

cancel
Showing results for 
Search instead for 
Did you mean: 
Member II

activiti with spring boot 2.1 or 2.2?

We are using activiti spring starter, the latest version I believe is 7.1.0.M6.

However, in our gradle build, it forced the spring boot to version 2.0.0.

That caused some compatibiity issues, i.e. we use spring-kafka that requires spring-boot 2.1 at lease.

Any way to upgrade activiti spring start so it works with spring boot 2.1 or even better 2.2?

Thanks.

2 Replies
Alfresco Employee

Re: activiti with spring boot 2.1 or 2.2?

the issue must be in your gradle build as in M6 the spring boot version used is 2.1.12.RELEASE:

https://github.com/Activiti/Activiti/blob/7.1.0.M6/pom.xml#L219

Alfresco Employee

Re: activiti with spring boot 2.1 or 2.2?

Spring Boot 2.2 support is currently WIP https://github.com/Activiti/Activiti/issues/3019

but for Activiti 7 and Cloud it's easier to ask questions on the gitter channel Gitter Chatroom