Admin app REST Endpoint does not work

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

Admin app REST Endpoint does not work

Jump to solution

Hello all. I get the license for trying the Alfresco Process Services.

On my Lubuntu 18.04 64bit, I installed and run the dockers of the main app and the admin app.

The main app is on http://localhost:8082 I tried the REST API accessing from browser http://localhost:8082/activiti-app/api/enterprise/admin/tenants . I get a good JSON response ( [{"id":1,"name":"trial"}] ).

On the admin app, running on http://localhost:8083 , the endpoint settings are:

Server address: http://localhost

Server port: 8082

Context root: activiti-app

REST root: api

Username: admin@app.activiti.com

Password: admin

Unluckily the endpoint does not work. Checking the AJAX call, the response is "Unable to connect to the Activiti server." The ports are open on the firewall ( sudo ufw allow 8082 && sudo ufw allow 8083 )

I'm using Alfresco Process Services v1.9.0 and Docker 18.06.1-ce, build e68fc7a

PS: the documentation and the server log about license is wrong. I tried to put it to $USER_HOME/.activiti/enterprise-license as documented, but it did not work. The log of Spring says the home was `root`, so I created under /root the directories, copied the license file and changed the ownership of the subfolders and the file to my user and the group to "docker". Nothing. I had to upload the license from interface.

1 Solution

Accepted Solutions
Highlighted
Active Member

Re: Admin app REST Endpoint does not work

Jump to solution

Ok, putting the id of the machine from `ifconfig` works.

Just for your information, the Activiti app accepts `localhost`...

View solution in original post

3 Replies
Highlighted
Active Member

Re: Admin app REST Endpoint does not work

Jump to solution

I also tried with this command without success:

docker run --name alfresco_admin -p 8083:8080 -d -e ACTIVITI_ADMIN_REST_APP_HOST='http://localhost' -e ACTIVITI_ADMIN_REST_APP_PORT='8082' -e ACTIVITI_ADMIN_REST_APP_USERNAME='admin@app.activiti.com' -e ACTIVITI_ADMIN_REST_APP_PASSWORD='admin' alfresco/process-services-admin

Highlighted
Moderator
Moderator

Re: Admin app REST Endpoint does not work

Jump to solution

If you are using Docker you can't set localhost as the endpoint of another Docker component, you should set the Docker Endpoint IP generated at runtime. Maybe the issue is just this.

Hope this helps.

Highlighted
Active Member

Re: Admin app REST Endpoint does not work

Jump to solution

Ok, putting the id of the machine from `ifconfig` works.

Just for your information, the Activiti app accepts `localhost`...

View solution in original post