Could not parse POM aoservices-2.12.7.2.pom

cancel
Showing results for 
Search instead for 
Did you mean: 
franciscoduarte
Member II

Could not parse POM aoservices-2.12.7.2.pom

Hi,

I'm upgrading APS from 1.10.0 to 1.11.4.

When gradle starts fetching the dependencies I'm getting this error:

> Could not resolve org.alfresco.officeservices:aoservices:2.12.7.2.
    > Could not parse POM https://artifacts.alfresco.com/nexus/content/repositories/activiti-enterprise-releases/org/alfresco/...

This is a repository with authentication and my credentials are correct.

This is my gradle file:

allprojects {
repositories {
maven {
credentials {
username "username"
password "password"
}
url 'https://artifacts.alfresco.com/nexus/content/repositories/activiti-enterprise-releases/'

}
mavenCentral()
maven {
url 'https://artifacts.alfresco.com/nexus/content/repositories/public/'
}
maven {
url 'https://artifact.aspose.com/repo/'
}
maven {
url('https://artifactory.local.com/artifactory/libs-snapshot')
metadataSources {
artifact()
}
}
mavenLocal()
}
}

Can someone help?

Francisco Duarte
1 Reply
openpj
Moderator
Moderator

Re: Could not parse POM aoservices-2.12.7.2.pom

Have you tried to manage your extensions using APS SDK?

The project will take care about dependencies for you and you only need to work on your extensions:

https://github.com/OpenPj/alfresco-process-services-project-sdk

Hope this helps Smiley Wink