Exclusive gateway not working.

cancel
Showing results for 
Search instead for 
Did you mean: 
Established Member

Exclusive gateway not working.

Jump to solution

Hi Team,

    I designed one process. if i am use exclusive gate way in that then it is raising an error like "ExclusiveGateway should have only one outgoing SequenceFlow".

Please check attachment and give reply.

if i placed exclusive gateway after "Reporting Manager Approval" then it is showing an error mentioned as above.

Thanks

1 Solution

Accepted Solutions
Established Member

Re: Exclusive gateway not working.

Jump to solution

Thank you it is worked

View solution in original post

4 Replies
Advanced II

Re: Exclusive gateway not working.

Jump to solution

Have you configured the output flows to have the required conditions?

Activiti User Guide 

And it would be better if you shared the diagram actually containing the exclusive gateway you tried.

Established Member

Re: Exclusive gateway not working.

Jump to solution

Hi,

    Thank you for your reply.

    My attachment is without exclusive gateways. I placed conditions in outflows. but if i placed exclusive gateway it is showing error like "ExclusiveGateway should have only one outgoing SequenceFlow".

     If you know anything about this, please let me know.

Thanks

Active Member

Re: Exclusive gateway not working.

Jump to solution

Hi,

Try to set a condition in one outgoing token and set the other token to default.

Established Member

Re: Exclusive gateway not working.

Jump to solution

Thank you it is worked

View solution in original post