Failed installation of Alfresco Process Services

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
tasse007
Member II

Failed installation of Alfresco Process Services

Jump to solution

Hi,

I downloaded Alfresco Process Services (APS) and copied the licence file activiti.lic in the folder:

process-services-1.9.0.3 --> tomcat --> Lib.

I changed the name of the activiti.admin.war.undeployed into activiti.admin.war and copied the file into the webapps folder of tomcat (which I have been installing on windows following a youtube video).

So basically I followed the instructions of the read me file to install APS but when I put http://localhost:8080/activiti-app  in one of my browsers (firefox/chrome/edge) this text occurs:

HTTP Status 404 – Not Found


Type Status Report

Message /activiti-app

Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.


Apache Tomcat/9.0.13

Can anyone help me please to finish the installation so I can log in to the workflow system?

Best regards,

Tass

1 Solution

Accepted Solutions
jtsmith
Active Member

Re: Failed installation of Alfresco Process Services

Jump to solution

From the catalina log, looks like you already have something running on port 8080, which is causing a conflict:

19-Nov-2018 11:42:13.754 SEVERE [main] org.apache.coyote.AbstractProtocol.init Failed to initialize end point associated with ProtocolHandler ["http-nio-8080"]
java.net.BindException: Address already in use: bind

You can modify the port in the tomcat/conf/server.xml

The DB properties look fine.

5 Replies
cjose
Senior Member II

Re: Failed installation of Alfresco Process Services

Jump to solution

You may have some errors in the tomcat log, you able to share them?

Also, make sure that you are not using the same database for both activiti-app and activiti-admin in their respective property files.

tasse007
Member II

Re: Failed installation of Alfresco Process Services

Jump to solution

Hello Ciju Joseph,

thank you for your answer. I'm not sure if the new attached text in LogFile_Acitiviti_Admin_App.txt  represents the logfiles you are looking for. If not, where can I find them?

I am sorry but I do not understand what you mean by saying:

"not using the same database for both activiti-app and activiti-admin in their respective property files."

How can I control or change that?

Best regards

 

Tass

jtsmith
Active Member

Re: Failed installation of Alfresco Process Services

Jump to solution

Tass,

In the tomcat/logs folder there are a couple different logs that you can reference to see how the startup is going. Also, in the tomcat/lib folder there are two properties files, activiti-app.properties and activiti-admin.properties, than you can use to specify which DBs they are using.    

tasse007
Member II

Re: Failed installation of Alfresco Process Services

Jump to solution

Hello JT Smith,

I found the folder and decided to upload the whole program in onedrive so we can have a look on it together.

https://1drv.ms/f/s!AjyKOOfK-4Hi7URdQ2_iqGd3fFOk

Now, we can also find the tomcat logfiles, Ciju Joseph‌.

I think activiti-admin.properties is using datasource.url=jdbc:h2:tcp://localhost:9092/activiti-admin

and activiti-app.properties is using datasource.url=jdbc:h2:tcp://localhost:9092/activiti.

Is this correct?

jtsmith
Active Member

Re: Failed installation of Alfresco Process Services

Jump to solution

From the catalina log, looks like you already have something running on port 8080, which is causing a conflict:

19-Nov-2018 11:42:13.754 SEVERE [main] org.apache.coyote.AbstractProtocol.init Failed to initialize end point associated with ProtocolHandler ["http-nio-8080"]
java.net.BindException: Address already in use: bind

You can modify the port in the tomcat/conf/server.xml

The DB properties look fine.