Failed to start activiti-admin with oracle database due to an error 'ORA-00904: "SERVERCONF0_"."PASSWORD": invalid identifier'

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Failed to start activiti-admin with oracle database due to an error 'ORA-00904: "SERVERCONF0_"."PASSWORD": invalid identifier'

I am new to Activiti. I have installed and run the db script in two oracle schemas: one for activiti-admin, the other for activiti-app. Activiti-app is running fine, but activiti-admin failed to start because of the following error. Please help. Thanks.

11:13:31,190 [main] DEBUG com.activiti.conf.DatabaseConfiguration  - Configuring Liquibase
11:13:32,408 [main] DEBUG com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool  - Testing PooledConnection [com.mchange.v2.c3p0.impl.NewPooledConnection@749a2cc4] on CHECKOUT.
11:13:32,424 [main] DEBUG com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool  - Test of PooledConnection [com.mchange.v2.c3p0.impl.NewPooledConnection@749a2cc4] on CHECKOUT has SUCCEEDED.
11:13:34,018 [C3P0PooledConnectionPoolManager[identityToken->2ym9xt9t18849bx17stx9u|23202c31]-HelperThread-#1] DEBUG com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool  - Testing PooledConnection [com.mchange.v2.c3p0.impl.NewPooledConnection@749a2cc4] on CHECKIN.
11:13:34,033 [C3P0PooledConnectionPoolManager[identityToken->2ym9xt9t18849bx17stx9u|23202c31]-HelperThread-#1] DEBUG com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool  - Test of PooledConnection [com.mchange.v2.c3p0.impl.NewPooledConnection@749a2cc4] on CHECKIN has SUCCEEDED.
11:13:34,127 [main] INFO  com.activiti.domain.generator.MinimalDataGenerator  - Verifying if minimal data is present
11:13:34,158 [main] DEBUG com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool  - Testing PooledConnection [com.mchange.v2.c3p0.impl.NewPooledConnection@749a2cc4] on CHECKOUT.
11:13:34,158 [main] DEBUG com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool  - Test of PooledConnection [com.mchange.v2.c3p0.impl.NewPooledConnection@749a2cc4] on CHECKOUT has SUCCEEDED.
11:13:34,674 [main] DEBUG com.mchange.v2.c3p0.impl.NewPooledConnection  - com.mchange.v2.c3p0.impl.NewPooledConnection@749a2cc4 handling a throwable.
java.sql.SQLSyntaxErrorException: ORA-00904: "SERVERCONF0_"."PASSWORD": invalid identifier

3 Replies
Highlighted
Member II

Re: Failed to start activiti-admin with oracle database due to an error 'ORA-00904: "SERVERCONF0_"."PASSWORD": invalid identifier'

I found both USER_INFO and SERVRE_CONFIG tables have a column "password". After I changed the column name to "PASSWORD", the 'ORA-00904: "SERVERCONF0_"."PASSWORD": invalid identifier' error was gone. I am curious to know why the column name "password" has all lower-case character, while other column names have all upper-case characters. Is this a liquibase problem with oracle dialect?

Highlighted
Senior Member II

Re: Failed to start activiti-admin with oracle database due to an error 'ORA-00904: "SERVERCONF0_"."PASSWORD": invalid identifier'

I presume that the problem is that 'password' is a reserved word in oracle. I am not sure why changing the case resolved it but I think it has something to do with How do I escape a reserved word in Oracle? - Stack Overflow . Some tables use a prefix before the column name for the password Activiti/db-changelog.xml at 6.x · Activiti/Activiti · GitHub  but that one doesn't Activiti/db-changelog.xml at 6.x · Activiti/Activiti · GitHub  .  

Highlighted
Member II

Re: Failed to start activiti-admin with oracle database due to an error 'ORA-00904: "SERVERCONF0_"."PASSWORD": invalid identifier'

Thank you.