Getting Content with id: 69 was not found (path: data/0/0/0/69) Exception

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Getting Content with id: 69 was not found (path: data/0/0/0/69) Exception

Hi,

I have a BPMN process model which is  having the  facility of generating letter templates using generate Document Task.

I am using custom template option in the generate document task configaution.when i deploy the process model  its worrking as  expected. However  when i  try to publish the new process version of that  process model and then try to restart the tomcat, the already created  process is throwing an exception like the below when try to generate the letter templates.

May i know why i am facing this issues. and help me on  sharing some thoughts on resolving this issues.

 

Content with id: 69 was not found (path: data/0/0/0/69) Exception

 

Thanks

Arun K

8 Replies
Highlighted
Member II

Re: Getting Content with id: 69 was not found (path: data/0/0/0/69) Exception

Hi, 

How do you publish the new version of the process?
If you do it by importing a process from a .zip file, enter the process editor and check if a document with a template is attached to the Generate Task.

Can you share screen from Document Task configuration before publish new version and after publish new version and restart tomcat? 

Highlighted
Member II

Re: Getting Content with id: 69 was not found (path: data/0/0/0/69) Exception

The entire  process model,form can be exported ass a  Zip file under the Apps section. and the App(bundled with process model,form) can be imported using the import app section.

 

i verfied all document templates  are available in the old process version and the new process model version as well.

However (as per my project  need after the the process model is published, it requires  tomcat need to be restarted).

After tomcat restart , i think under  data directoy in tomcat something is happening, thus making the  already running process forced to throw the above exception  when try to generate the document.

 

Thanks

Arun K

Highlighted
Senior Member

Re: Getting Content with id: 69 was not found (path: data/0/0/0/69) Exception

Your Speculation is correct. the tenant wide document templates are stored in act_data folder.

# default Content Storage

contentstorage.fs.rootFolder=./act_data/data

if not provided, this folder is generated inside the executing folder (from where you executed catalina.bat).

for example, if you were previously running APS instance from /tomcat/bin directory you'll see the act_data folder created in bin by APS. however if you switched the directory and tried running APS instance from tomcat home directory. a new act_data will be created in the tomcat folder. since your template was saved in the old directory. you'll receive the said exception.

to resolve this issue. set

contentstorage.fs.rootFolder

or make sure to start tomcat from dir where act_data was generated first.

hope it helps.

Regards,
Abbas
Highlighted
Member II

Re: Getting Content with id: 69 was not found (path: data/0/0/0/69) Exception

Hi,

 

Thanks for your comment.

in my case,  the contentstorage.fs.rootFolder=data/  is set already

and the data folder is created under tomcat bin directory.

whenever after the new deployment, i need to restart the tomcat. i usually restart the tomcat  going into bin directory(where data folder is there) and then ./shutdown.sh and then ./startup.sh

after i did this, the already running process is  throwing an exception content -id not found when i try to generate  the document from the already running process.

 

AM i missing anything here. could you please suggest your thoughts please.

 

Thanks

Arun K

 

Highlighted
Senior Member

Re: Getting Content with id: 69 was not found (path: data/0/0/0/69) Exception

do you still see the referred document in Identity Management > Tenants > Document Templates with the same name as before? the file name must be unique, and must not be changed.

Regards,
Abbas
Highlighted
Member II

Re: Getting Content with id: 69 was not found (path: data/0/0/0/69) Exception

Hi,

 

Thanks for your response. I am not adding the document template under Identity Management.

I am adding the  templates in the custom template section of the generate document task of the process model.

The name of the templates are same.

 

Image1Image1Image2Image2

 

Thanks

Arun K

Highlighted
Member II

Re: Getting Content with id: 69 was not found (path: data/0/0/0/69) Exception

Hi,

 

Could you please help on sharing your thoughts please.

Am i missing anything here.

 

Thanks

Arun K

Highlighted
Senior Member

Re: Getting Content with id: 69 was not found (path: data/0/0/0/69) Exception

try the tenant wide doc templates, see if the problem persists - https://docs.alfresco.com/process-services1.11/topics/document_templates.html

Regards,
Abbas